Unable to install Ubuntu Mate and Vanilla Ubuntu together for dual boot on a UEFI system (primary bug reported for Ubiquity, but a narrow fix could be implemented by Mate)

Bug #1855896 reported by GizmoChicken on 2019-12-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
ubiquity
New
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

I reported for Ubiquity a bug in which, when using the "something else" installation mode (which I must use for various reasons), a second Ubuntu installation overwrites the /EFI/ubuntu (on ESP) for a first Ubuntu installation, preventing me from booting into the first Ubuntu installation without workarounds. See https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1855874

REGARDING MATE: As I mention in the above linked bug report, at least when using the "something else" installation mode, attempting to install Ubuntu Mate alongside vanilla Ubuntu ALSO triggers the above described bug. That is, installing Ubuntu Mate also overwrites previous instances of /EFI/ubuntu on the ESP.

SUGGESTION: By default, Ubuntu Mate should install EFI files to /EFI/ubuntu-mate (and not to /EFI/ubuntu) on the ESP, which would overcome this issue for Ubuntu Mate users.

Please note that my suggestion would also benefit those Mate users who don't dual boot, in that those users would see an UEFI NVRAM entry that lists Ubuntu Mate rather than seeing seeing a UEFI NVRAM that list vanilla Ubuntu, but that actually boots Ubuntu Mate, as is the current situation.

Of course, fixing the underlying issue in Ubiquity would be even better. But in the meantime, the above suggestion would at least overcome the issue for those who want to dual boot Ubuntu Mate and Vanilla Ubuntu on the same UEFI system.

Norbert (nrbrtx) on 2020-03-22
tags: added: eoan
Changed in ubuntu-mate:
status: New → Incomplete
Norbert (nrbrtx) on 2020-08-02
Changed in ubiquity (Ubuntu):
status: New → Incomplete
Steve Langasek (vorlon) on 2020-08-02
Changed in ubiquity (Ubuntu):
status: Incomplete → New
Changed in ubuntu-mate:
status: Incomplete → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers