installing ubiquity on efi system tries to remove grub-efi-amd64

Bug #1848880 reported by Ozzy on 2019-10-19
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Mathieu Trudel-Lapierre
Bionic
Undecided
Unassigned

Bug Description

[impact]
OEM mode on server is broken on UEFI systems.

[test case]
Install a UEFI system using the d-i installer in oem mode and check if the oem-config-prepare binary is present after rebooting.

[regression potential]
The change is replacing a transitional package in Recommends with the package the transitional package depends upon, so it is extremely hard to think of how this would cause unexpected fallout.

[original description]
Selecting the OEM Install option when installing 18.04.3 does not seem to allow for an OEM install. There are no indications of it being an OEM
install on the installer screen as in previous versions, and after installation the command oem-config-prepare is not found.

Related branches

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1848880/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Ozzy (theciscogeek) on 2019-10-20
affects: ubuntu → debian-installer (Ubuntu)
Ozzy (theciscogeek) on 2019-10-20
summary: - Server 18.04.3 OEM Install option doesn't work
+ Server 18.04.3-live OEM Install option doesn't work

When going through the same process on ubuntu-18.04.3-server-amd64 (as opposed to the live-server iso), the installer displays "OEM mode (for manufacturers only)" as expected. Although oem-config-prepare is still not found once booted into the freshly installed instance.

summary: - Server 18.04.3-live OEM Install option doesn't work
+ Server 18.04.3 OEM Install option doesn't work
tags: added: bionic
tags: added: rls-bb-incoming

The fact that there is no oem-config-prepare / OEM mode on the live-server image is a known thing; I don't think that has been implemented at all in subiquity yet.

However, you really should have has oem-config-prepare available at the end of an OEM install from the server image; I'll investigate why that wasn't the case, first by trying to reproduce the issue.

Changed in debian-installer (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
tags: added: id-5db75008c942e44a026044e7
Michael Hudson-Doyle (mwhudson) wrote :

I downloaded the ubuntu-18.04.3-server.iso and completed an install in oem-mode that appeared to work as designed. I logged in as the oem user, ran oem-config-prepare and went through oem-config on the next boot. So I'm not sure what the bug is here.

Changed in debian-installer (Ubuntu):
status: New → Incomplete
Ozzy (theciscogeek) wrote :

I can't tell you how many times I tried this and each time was the same - menu showed OEM mode, but oem-config-prepare was not found once booted. I had even downloaded ubuntu-18.04.3-server.iso, ubuntu-18.04.2-server.iso, ubuntu-18.04.1-server.iso, and the original 18.04-server and tried with them to no avail.

Today, after seeing your comment I decided to try it again with the same exact steps and it worked! While intensely curious as to why it didn't work before, I will just be thankful that it does now so I can create my template VM :-)

If it resurfaces at a later date, I will bring it up again (with logs of some sort and maybe a video so I don't seem as crazy).

Ozzy (theciscogeek) wrote :

I had it happen again, and was able to reproduce while recording. Attached is video of me installing in OEM mode and then oem-config-prepare being unavailable. Please let me know if there is anything else I can provide. This was with the same 18.04.3-server iso.

Ozzy (theciscogeek) wrote :

I did some more testing and found the common denominator on the machines that it's not working for me on.

It seems that this affects machines with UEFI, but not Legacy (BIOS) booting. To verify I created two identical VM's in vmware esxi 6.7u3, set one to EFI boot and the other to BIOS. The Legacy/BIOS boot VM worked normally, however the VM set to EFI boot exhibited "command not found" when attempting to run oem-config-prepare. Apart from BIOS vs UEFI, all other aspects of the VM were the same.

Michael Hudson-Doyle (mwhudson) wrote :

Oh good spot. So the issue is that the install of oem-config-debconf at the end of the install fails because ubiquity's recommends did not get updated to care about the split of grub-efi into grub-efi-amd64 and grub-efi-arm64. We can fix this in ubiquity I think.

affects: debian-installer (Ubuntu) → ubiquity (Ubuntu)
summary: - Server 18.04.3 OEM Install option doesn't work
+ installing ubiquity on efi system tries to remove grub-efi-amd64
Changed in ubiquity (Ubuntu):
status: Incomplete → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 20.04.3

---------------
ubiquity (20.04.3) focal; urgency=medium

  [ Michael Hudson-Doyle ]
  * d/control: Recommend grub-efi-amd64 or grub-efi-ia32, not the transitional
    grub-efi which is no longer installed by default. (LP: #1848880)

 -- Steve Langasek <email address hidden> Mon, 02 Dec 2019 12:48:01 -0800

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
description: updated
description: updated

Hello Ozzy, or anyone else affected,

Accepted ubiquity into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubiquity/18.04.14.13 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubiquity (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers