installer crashed - Cannot resolve path /dev/sdN - Failed to mount /target

Bug #1847748 reported by John Lenton on 2019-10-11
40
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Jean-Baptiste Lallement
Eoan
Critical
Jean-Baptiste Lallement

Bug Description

installer crashed, shortly after asking me for user details.
In case it's relevant, this is a fairly old machine (surprised it can run x86_64), but with ~4G ram and an nvidia card (that's not happy with nouveau).

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: ubiquity 19.10.18
ProcVersionSignature: Ubuntu 5.3.0-17.18-generic 5.3.1
Uname: Linux 5.3.0-17-generic x86_64
NonfreeKernelModules: nvidia zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
CasperVersion: 1.424
CurrentDesktop: MATE
Date: Fri Oct 11 12:31:59 2019
InstallCmdLine: file=/cdrom/preseed/ubuntu-mate.seed initrd=/casper/initrd quiet splash nomodeset ---
LiveMediaBuild: Ubuntu-MATE 19.10 "Eoan Ermine" - Beta amd64 (20191011)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

John Lenton (chipaca) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Here is the issue from the logs

Oct 11 11:21:16 ubuntu-mate ubiquity: The partition table has been altered.
Oct 11 11:21:16 ubuntu-mate ubiquity: Calling ioctl() to re-read partition table.
Oct 11 11:21:16 ubuntu-mate ubiquity: Re-reading the partition table failed.
Oct 11 11:21:16 ubuntu-mate ubiquity: : Device or resource busy
Oct 11 11:21:16 ubuntu-mate ubiquity: The kernel still uses the old table. The new table will be used at the next reboot or after you run partprobe(8) or kpartx(8).
Oct 11 11:21:16 ubuntu-mate ubiquity: Synching disks.
Oct 11 11:21:16 ubuntu-mate ubiquity: I: Initializing ZFS
Oct 11 11:21:16 ubuntu-mate ubiquity: cannot resolve path '/dev/sda6'

We used partprobe originally but then the installer fails to mount /target because the partition table is not ready when it attempts to mount it.

Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Jean-Baptiste Lallement (jibel)
summary: - installer crashed
+ installer crashed - Cannot resolve path /dev/sdN - Failed to mount
+ /target
Jean-Baptiste Lallement (jibel) wrote :

I can reproduce this problem and similar on a system with fast drives and going quickly through the timezone and user details steps. We start altering the disk while partman hasn't yet finish to prepare it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 19.10.20

---------------
ubiquity (19.10.20) eoan; urgency=medium

  [ Jean-Baptiste Lallement ]
  * zsys-setup: Force a re-read of the partition table before using the disk
    (LP: #1847748)

  [ Iain Lane ]
  * zsys-setup: Mark packages to kept in the init phase, rather than finalize.
    Finalize runs after ubiquity has removed files from packages which it has
    decided the target system isn't going to need. It's too late for us to try
    to save things then. (LP: #1847898)

  [ Dimitri John Ledkov ]
  * Automatic update of included source packages: partman-auto
    134ubuntu12, partman-base 206ubuntu6 (LP: #1847944)

 -- Dimitri John Ledkov <email address hidden> Mon, 14 Oct 2019 14:31:19 +0100

Changed in ubiquity (Ubuntu Eoan):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers