ubiquity-dm (maybe-ubiquity/only-ubiquity) missing keyboard indicator, when booted into Esc, Russian locale by default from isolinux BIOS boot

Bug #1847307 reported by corrado venturini on 2019-10-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
Focal
High
Unassigned

Bug Description

[Impact]

 * In ubiquity-dm (aka "maybe-ubiquity" or "only-ubiquity" modes) the keyboard indicator is not shown. Thus users cannot change keyboard layouts to input fields in various languages.

[Test Case]

 * Boot installer in Russian language, i.e. only-ubiquity --- debian-installer/language=ru keyboard-configuration/layoutcode?=ru

 * Observe that the installer boots into Russian language by default

 * Observe that in the top right corner there is a keyboard layout indicator drop down, and it contains "en" and "ru" layouts.

[Regression Potential]

 * Starting additional service during minimal ubiquity-dm will increase slightly cpu/ram usage. However, it should still be well within the declared RAM requirements.

[Other Info]

 * Original bug report

I installed (overwriting an existing partition) from Ubuntu 19.10 "Eoan Ermine" - Beta amd64 (20191006) selecting "Language": "en_US" and keyboard italian. When i entered the computer name "corrado-p6-ee-1006" i see instead "corrado/p6/ee/1006" because the installer uses the US keyboard so i was forced to enter the computer name considering i have an US keyboard

{"Media": "Ubuntu 19.10 \"Eoan Ermine\" - Beta amd64 (20191006)", "Type": "GTK", "OEM": false, "PartitionMethod": "manual", "DownloadUpdates": true, "Language": "en", "Minimal": false, "RestrictedAddons": true, "Stages": {"0": "language", "1": "language", "5": "console_setup", "11": "console_setup", "19": "prepare", "130": "partman", "136": "partman", "142": "partman", "166": "partman", "172": "partman", "178": "timezone", "182": "usersetup", "253": "user_done", "815": "done"}}

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 5.3.0-13.14-generic 5.3.0
Uname: Linux 5.3.0-13-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Oct 8 18:25:48 2019
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed only-ubiquity quiet splash ---
InstallationDate: Installed on 2019-10-08 (0 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Beta amd64 (20191006)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Sebastien Bacher (seb128) wrote :

I'm seeing a similar issue on 19.10 doing a french install on an uefi machine
- boot from the usb stick with Ubuntu Desktop 19.10
- select the 'install' item from the text-mode-menu
- in ubiquity select french
- keep the default selected keyboard (french - alternative)
-> typing on that screen the layout is azerty
- using custom partitioning (in case that makes a difference)
- on the user creation page, the layout is english/qwerty

tags: added: rls-ff-incoming
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

Thinking about it, it's probably wrong on the partionner step as well since for entering digit I had to not-use-shift where you need to do that with the french layout

Changed in ubiquity (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
tags: removed: rls-ff-incoming
tags: added: id-5dd2ea55fdf398529874bf28
Dimitri John Ledkov (xnox) wrote :

Check that this is not a duplicate of the keyboard bug https://wiki.ubuntu.com/Ubiquity/KeyboardBug

I can't remember, but i think one only gets the full localised keyboard if one uses 1) bios boot 2) picks language at isolinux time

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Michael Hudson-Doyle (mwhudson) wrote :

I can't reproduce this with the latest focal daily -- I followed the instructions from comment #2 as closely as I could UEFI, selecting install from boot menu, french language, french keyboard, custom partitioning, and the layout was still active in the user creation screen. It was a VM rather than real hardware but if that matters I'm going to cry :)

Let me know if there is a way to reproduce and I'll look into it.

Changed in ubiquity (Ubuntu Focal):
status: Confirmed → Incomplete
Michael Hudson-Doyle (mwhudson) wrote :

PS: I tested the ISO with serial 20200413

Rudra Saraswat (rs2009) on 2020-05-18
Changed in ubiquity (Ubuntu):
status: Incomplete → Invalid
Changed in ubiquity (Ubuntu Focal):
status: Incomplete → Invalid
Changed in ubiquity (Ubuntu):
status: Invalid → Incomplete
Changed in ubiquity (Ubuntu Focal):
status: Invalid → Incomplete
Dimitri John Ledkov (xnox) wrote :

I used BIOS boot, and preseed Esc at the burning-person screen, and selected Russian option from the language selection.

This way, russian locale is appended to the kernel commandline and upon live session boot, I expect Russian locale to be selected for everything, and Russian/English keyboards available.

Booting into "only-ubiquity" mode, keyboard selection indicator is missing and pressing "super+space" doesn't change keyboard layout either.

If on the other hand I boot into full live session, I see that there is keyboard selection indicator and I can change keyboard layouts with "super+space".

It seems like "keyboard-indicator" is missing from the "maybe-ubiquity/only-ubiquity" ubiquity-dm session.

Changed in ubiquity (Ubuntu):
status: Incomplete → Triaged
Changed in ubiquity (Ubuntu Focal):
status: Incomplete → Triaged
summary: - Install in english with italian keyboard - keyboard not set during
- install
+ ubiquity-dm (maybe-ubiquity/only-ubiquity) missing keyboard indicator,
+ when booted into Esc, Russian locale by default from isolinux BIOS boot
Dimitri John Ledkov (xnox) wrote :

However, ubiquity.json gnome-shell mode does have:

"right": ["a11y", "keyboard", "aggregateMenu"]

i wonder why it doesn't show up.....

Dimitri John Ledkov (xnox) wrote :

Oooh, gsd-keyboard is missing

description: updated
no longer affects: gnome-shell (Ubuntu)
no longer affects: gnome-shell (Ubuntu Focal)
Changed in ubiquity (Ubuntu):
assignee: Łukasz Zemczak (sil2100) → nobody
Changed in ubiquity (Ubuntu Focal):
assignee: Łukasz Zemczak (sil2100) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 20.10.4

---------------
ubiquity (20.10.4) groovy; urgency=medium

  [ Dimitri John Ledkov ]
  * d-i: drop distro patch of partman-swapfile, included in v2
  * d-i: vendorize archdetect binary, to remove hw-detect
  * Do not vendorize shim-signed scripts, simply use shim-signed scripts
    that are installed in live session already anyway.
  * ubiquity-dm: start gsd-keyboard for keyboard indicator (LP: #1847307)
  * autopilot: pacify new pyflakes

  [ Jean-Baptiste Lallement ]
  * Calculate partition number instead of reusing swap
  * Add partition for key store.
  * Add creation of the key store
  * Key store on ZVol
  * Encryption is enabled with --encrypt|-e
  * Added encrypted swap on ZFS systems
  * Use env instead argument to enable encryption
  * Properly calculate position of extended partition
  * force key when zfs encryption is activated.
  * Properly unmount target and its friends on zfs installation.
  * Add ZFS encryption UI
  * partition table is always GPT
  * Various fixes in zsys-setup
  * Moved keystore to /run/

 -- Dimitri John Ledkov <email address hidden> Mon, 15 Jun 2020 18:18:40 +0100

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released

Hello corrado, or anyone else affected,

Accepted ubiquity into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubiquity/20.04.15.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubiquity (Ubuntu Focal):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-focal

SRU verification for Focal:
I have reproduced the problem with ubiquity 20.04.15 in focal and have verified that the version of ubiquity 20.04.15.1 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 20.04.15.1

---------------
ubiquity (20.04.15.1) focal; urgency=medium

  [ Sebastien Bacher ]
  * debian/real-po: updated translations from launchpad, including strings
    from the new subpage for RST (LP: #1874103)

  [ Michael Hudson-Doyle ]
  * make grub_default consider the boot argument in the non-removable case
    (LP: #1847898)

  [ Jean-Baptiste Lallement ]
  * Enable ZFS autotrim (LP: #1883686)
  * Use persistent path for pool's vdevs (LP: #1880869)
  * Do not export all pools (LP: #1875045)

  [ Dimitri John Ledkov ]
  * ubiquity-dm: start gsd-keyboard for keyboard indicator (LP: #1847307)

 -- Dimitri John Ledkov <email address hidden> Tue, 16 Jun 2020 11:17:42 +0100

Changed in ubiquity (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubiquity has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers