Installer crashes at partitioning stage

Bug #1847228 reported by Kishore on 2019-10-08
62
This bug affects 8 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned
Eoan
Undecided
Unassigned
ubiquity (Ubuntu)
Critical
Jean-Baptiste Lallement
Eoan
Critical
Jean-Baptiste Lallement

Bug Description

When i chose to "Manual" mode and click "Next", i get an installer crashed with the following log.

Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 1078, in on_next_clicked
    self.dbfilter.ok_handler()
  File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 3262, in ok_handler
    if self.ui.use_zfs.get_active() and method == 'use_device':
AttributeError: 'PageKde' object has no attribute 'use_zfs'

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: ubiquity 19.10.15 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 5.3.0-13.14-generic 5.3.0
Uname: Linux 5.3.0-13-generic x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CurrentDesktop: KDE
Date: Tue Oct 8 10:33:01 2019
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/kubuntu.seed only-ubiquity quiet splash oem-config/enable=true ---
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Kishore (kitts) wrote :
Rik Mills (rikmills) on 2019-10-08
Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
tags: added: rls-ee-incoming
Changed in ubiquity (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
tags: removed: rls-ee-incoming
Changed in ubiquity (Ubuntu Eoan):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.128ubuntu14

---------------
grub-installer (1.128ubuntu14) eoan; urgency=medium

  * When running on a ZFS filesystem udevadm returns an error
    which can be ignored. (LP: #1847228)
  * On zfs 0.8 cache is in /etc, do not attempt to copy it from
    /boot/zfs when it doesn't exist.

 -- Jean-Baptiste Lallement <email address hidden> Tue, 08 Oct 2019 11:24:14 +0200

Changed in grub-installer (Ubuntu Eoan):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 19.10.16

---------------
ubiquity (19.10.16) eoan; urgency=medium

  [ Iain Lane ]
  * Drop zfs-0.8-support.patch. We're goind to do this via the main
    grub-installer package in the archive instead.
  * ubi-partman.py: Handle ZFS option not being implemented on KDE frontend
    (LP: #1847228)
  * Automatic update of included source packages: grub-installer
    1.128ubuntu14. (LP: #1847211)

  [ Michael Hudson-Doyle ]
  * ubiquity/install_misc.py:do_install: mark any already-installed packages
    as manually installed. (LP: #1841672)

 -- Iain Lane <email address hidden> Tue, 08 Oct 2019 17:16:13 +0100

Changed in ubiquity (Ubuntu Eoan):
status: Triaged → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1847228

tags: added: iso-testing
FranksMCB (franksmcb) wrote :

ZFS install works correctly in Ubuntu MATE 20191009.1

Thiago Martins (martinx) wrote :

The ZFS option crashed the installer, I'll try again today!

FranksMCB (franksmcb) wrote :

ZFS installer works correctly in Ubuntu MATE 20191012 however after reboot to complete the install it boots directly into initramfs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers