Installation crashes with "Free software only" option enabled.

Bug #1845593 reported by Jean-Baptiste Lallement on 2019-09-27
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Jean-Baptiste Lallement
Eoan
Critical
Jean-Baptiste Lallement

Bug Description

Ubuntu Deskto 20190926.1

Test Case:
On the boot screen, press a key, F6 and select "Free Software Only" then proceed with installation as usual.

p 27 05:33:46 ubuntu ubiquity: Traceback (most recent call last):
Sep 27 05:33:46 ubuntu systemd[1249]: Starting Notification regarding a crash report...
Sep 27 05:33:46 ubuntu ubiquity: File "/usr/share/ubiquity/install.py", line 761, in <module>
Sep 27 05:33:46 ubuntu update-notifier-crash[12815]: /usr/bin/whoopsie
Sep 27 05:33:46 ubuntu ubiquity: install = Install()
Sep 27 05:33:46 ubuntu ubiquity: File "/usr/share/ubiquity/install.py", line 79, in __init__
Sep 27 05:33:46 ubuntu ubiquity: self.generate_blacklist()
Sep 27 05:33:46 ubuntu ubiquity: File "/usr/share/ubiquity/install.py", line 268, in generate_blacklist
Sep 27 05:33:46 ubuntu ubiquity: cache[pkg].section.startswith('restricted/')):
Sep 27 05:33:46 ubuntu ubiquity: AttributeError: 'Package' object has no attribute 'section'

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: ubiquity 19.10.12
ProcVersionSignature: Ubuntu 5.3.0-10.11-generic 5.3.0-rc8
Uname: Linux 5.3.0-10-generic x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CasperVersion: 1.419
Date: Fri Sep 27 01:34:02 2019
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed initrd=/casper/initrd quiet splash --- apt-setup/restricted=false apt-setup/multiverse=false
LiveMediaBuild: Ubuntu 19.10 "Eoan Ermine" - Beta amd64 (20190926.1)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
tags: added: rls-ee-incoming
Jean-Baptiste Lallement (jibel) wrote :

python-apt (1.9.0) experimental; urgency=medium

  * Port to APT 1.9.0; incompatible changes:
    [...]
    - Remove Package.section attributes

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1845593

tags: added: iso-testing
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
Changed in ubiquity (Ubuntu):
assignee: nobody → Jean-Baptiste Lallement (jibel)
Julian Andres Klode (juliank) wrote :

Use Version.section

Changed in ubiquity (Ubuntu Eoan):
status: Triaged → Fix Committed
Norbert (nrbrtx) wrote :

Ubuntu-MATE 19.10 _Eoan Ermine_ - Beta amd64 (20190928) ISO image is affected too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 19.10.13

---------------
ubiquity (19.10.13) eoan; urgency=medium

  [ Jean-Baptiste Lallement ]
  * scripts/install.py: Replaced removed property Package.section by
    Version.section (LP: #1845593)

  [ Iain Lane ]
  * nm.py: Stop referencing udevadm by absolute path
    systemd 242-6ubuntu1 dropped a `/sbin/ubiquity` compatibility symlink
    that we were referencing by absolute path. This broke ubiquity when run
    on a system with a wireless adapter. Fix this by not referencing an
    absolute path but using normal $PATH lookup instead. (LP: #1845730)

 -- Iain Lane <email address hidden> Fri, 27 Sep 2019 09:44:57 +0200

Changed in ubiquity (Ubuntu Eoan):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers