UEFI install is using fallback manager not mutter

Bug #1845432 reported by fossfreedom
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Iain Lane

Bug Description

Todays ubuntu budgie daily 26th Sept 2019, I am following the UEFI Install test case (no network) [http://iso.qa.ubuntu.com/qatracker/milestones/406/builds/200037/testcases/1699/results].

The installer is not themed and it looks like its using the fallback manager not mutter.

Will attach a screenshot

After installation, all is well.

This is a regression - all was working with yesterdays (25th) build

Revision history for this message
fossfreedom (fossfreedom) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1845432

tags: added: iso-testing
Revision history for this message
fossfreedom (fossfreedom) wrote :
summary: - EFI install is using fallback manager not mutter
+ UEFI install is using fallback manager not mutter
description: updated
description: updated
tags: added: ubiquity-19.10.11
tags: added: eoan
Revision history for this message
fossfreedom (fossfreedom) wrote :

guessing https://launchpadlibrarian.net/444161886/ubiquity_19.10.10_19.10.11.diff.gz

that this bit might be affecting UB

@@ -533,8 +534,7 @@
                        '/usr/lib/gnome-settings-daemon/gsd-a11y-settings',
                        '/usr/lib/gnome-settings-daemon/gsd-clipboard',
                        '/usr/lib/gnome-settings-daemon/gsd-media-keys',
- '/usr/lib/gnome-settings-daemon/gsd-power',
- '/usr/lib/gnome-settings-daemon/gsd-xsettings']
+ '/usr/lib/gnome-settings-daemon/gsd-power']

Revision history for this message
Iain Lane (laney) wrote :

That seems likely - I suggest one of two things

  1) budgie starts spawning gsd-xsettings on demand like gnome-shell does
  2) (easier) modify bin/ubiquity-dm to only *not* launch gsd-xsettings on gnome-shell

are you up for supplying one of those changes? If (2) I'll review / upload for you. It probably looks like (in bin/ubiquity-dm in ubiquity git):

if "gnome-shell" not in wm_cmd:
    gsd += ['/usr/lib/gnome-settings-daemon/gsd-xsettings']

just after the bit where we set "gsd".

Adam Conrad (adconrad)
Changed in ubiquity (Ubuntu):
status: New → Fix Committed
assignee: nobody → Iain Lane (laney)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 19.10.12

---------------
ubiquity (19.10.12) eoan; urgency=medium

  * ubiquity-dm: Still start gsd-xsettings for non-gnome-shell desktops.
    Apparently budgie wants this. (LP: #1845432)

 -- Iain Lane <email address hidden> Thu, 26 Sep 2019 17:38:45 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers