Flavors should use their slideshows when shipping to the end user

Bug #1842047 reported by Norbert
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Confirmed
Wishlist
Unassigned
Impish
Confirmed
Wishlist
Unassigned
ubiquity-slideshow-ubuntu (Ubuntu)
Triaged
Undecided
Martin Wimpress 
Impish
Triaged
Undecided
Martin Wimpress 
ubuntu-mate-meta (Ubuntu)
Invalid
Undecided
Unassigned
Impish
Invalid
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Download Ubuntu MATE ISO (20190830 in this case)
2. Boot it and select OEM install
3. Install the system, reboot and login to it
4. Click on "Prepare for shipping to end user"
5. Reboot and follow oem-config wizard instructions

Expected results:
* the MATE slideshow is shown during work of oem-config

Actual results:
* the Ubuntu slideshow is shown during work of oem-config

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: ubiquity 19.10.9
ProcVersionSignature: Ubuntu 5.2.0-15.16-generic 5.2.9
Uname: Linux 5.2.0-15-generic x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CurrentDesktop: MATE
Date: Fri Aug 30 12:38:23 2019
InstallCmdLine: file=/cdrom/preseed/ubuntu-mate.seed only-ubiquity initrd=/casper/initrd quiet splash --- oem-config/enable=true
InstallationDate: Installed on 2019-08-30 (0 days ago)
InstallationMedia: Ubuntu-MATE 19.10 "Eoan Ermine" - Alpha amd64 (20190830)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Norbert (nrbrtx) wrote :
Revision history for this message
Norbert (nrbrtx) wrote :

$ apt-cache policy oem-config-slideshow-ubuntu-mate
oem-config-slideshow-ubuntu-mate:
  Installed: (none)
  Candidate: 146
  Version table:
     146 500
        500 http://ru.archive.ubuntu.com/ubuntu eoan/universe amd64 Packages

$ dpkg -l | grep oem
ii oem-config 19.10.9 all Perform end-user configuration after initial OEM installation
ii oem-config-gtk 19.10.9 all GTK+ frontend for end-user post-OEM-install configuration
ii oem-config-slideshow-ubuntu 146 all OEM slideshow for Ubuntu

$ apt-cache rdepends oem-config-slideshow-ubuntu-mate
oem-config-slideshow-ubuntu-mate
Reverse Depends:

Revision history for this message
Norbert (nrbrtx) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oem-config (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Confirmed
Changed in ubuntu-mate-meta (Ubuntu):
status: New → Confirmed
Changed in ubuntu-mate-meta (Ubuntu):
status: Confirmed → Invalid
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Martin Wimpress (flexiondotorg)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 149

---------------
ubiquity-slideshow-ubuntu (149) eoan; urgency=medium

  [ Martin Wimpress ]
  * Update Ubuntu MATE slides to reflect new default apps.
    (LP: #1843297, #1843311)
  * debian/control:
    + Change Conflicts/Replaces from oem-config-slideshow-ubuntu to
      oem-config-slideshow for oem-slideshow-ubuntu-{mate,budgie}
      (LP: #1842047, #1713720)

 -- Sebastien Bacher <email address hidden> Tue, 01 Oct 2019 18:28:07 +0200

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Norbert (nrbrtx) wrote :

Ubuntu MATE focal 20200420 is still affected. And Xubuntu 20200420.1 too.

tags: added: focal
summary: - `ubiquity` from Ubuntu MATE ISO should install `oem-config-slideshow-
- ubuntu-mate` for `oem-config`
+ Flavors should use their slideshows in oem-config
Revision history for this message
Yousuf 'Jay' Philips (philipz85) wrote : Re: Flavors should use their slideshows in oem-config

I tried the 2021-03-08 Xubuntu ISO and saw no slides.

tags: added: rls-hh-incoming
Norbert (nrbrtx)
tags: added: groovy hirsute
removed: eoan
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

we should install matching slideshow when install oem-config into target.... not sure how we can ensure that only the right slideshow is in the /pool/ and in-target for oem-config installs.

Changed in ubiquity (Ubuntu):
importance: Undecided → Wishlist
no longer affects: oem-config (Ubuntu)
tags: added: rls-hh-notfixing
removed: rls-hh-incoming
Revision history for this message
Brian Murray (brian-murray) wrote : Re: [Bug 1842047] Re: Flavors should use their slideshows in oem-config

On Fri, Mar 12, 2021 at 09:46:37PM -0000, Yousuf 'Jay' Philips wrote:
> I tried the 2021-03-08 Xubuntu ISO and saw no slides.

Was this when you were performing an OEM install?

--
Brian Murray

tags: added: rls-hh-incoming
tags: added: rls-ii-incoming
removed: rls-hh-incoming
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Released → Triaged
summary: - Flavors should use their slideshows in oem-config
+ Flavors should use their slideshows when shipping to the end user
tags: added: fr-1318
Norbert (nrbrtx)
tags: added: impish
tags: removed: rls-ii-incoming
Revision history for this message
Norbert (nrbrtx) wrote :

MATE impish alpha 20210530 is still affected

Revision history for this message
Norbert (nrbrtx) wrote :

Ubuntu MATE impish alpha 20210721 is still affected.
The 22.04 LTS should have this fix applied.

Norbert (nrbrtx)
tags: removed: groovy
Revision history for this message
Norbert (nrbrtx) wrote :

Still happens on Ubuntu MATE 20211221 ISO.

tags: added: jammy rls-jj-incoming
Dave Jones (waveform)
tags: removed: rls-jj-incoming
Revision history for this message
Norbert (nrbrtx) wrote (last edit ):

Please fix this bug in next 22.04 LTS release.

Revision history for this message
Norbert (nrbrtx) wrote :

Still happens on Jammy. Should be fixed before final release.

Revision history for this message
Norbert (nrbrtx) wrote :

Still happens on Jammy. Should be fixed before final release!!!!11111

tags: removed: hirsute rls-hh-notfixing ubiquity-19.10.9
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers