Ubiquity fails to boot when selecting the Try Kubuntu (live session).

Bug #1808657 reported by Darin Miller on 2018-12-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

When booting to a live usb via UEFI boot on a hybrid Dell Inspiron 7559 laptop (Intel/Nvidia), the Try "Kubuntu option" hangs. If maybe-ubiquity is removed from the boot parameters, the laptop will live boot without issue. Proceeding directly to install works fine.

Another workaround is to add "nomodeset" to the boot parameters. But nomodeset forces a VGA boot. VGA on a 4k screen provides a very poor Live session experience.

I will reboot again with quiet mode disabled to see if any additional errors are displayed.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: ubiquity 19.04.3.1
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu14
Architecture: amd64
CasperVersion: 1.401
CurrentDesktop: KDE
Date: Sat Dec 15 22:54:40 2018
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/kubuntu.seed boot=casper quiet splash ---
LiveMediaBuild: Kubuntu 19.04 "Disco Dingo" - Alpha amd64 (20181214)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Darin Miller (darinmiller) wrote :
Darin Miller (darinmiller) wrote :

Removing the maybe-ubiquity from the boot params, booted to live session 3 out 3 attempts.

Sometimes the ubiquity boot will fail before the Try/Install menu is displayed as shown in the attachment. And it on this hybrid hardware, Try Kubuntu option always fails (assuming the ubiquity reaches that point).

Darin Miller (darinmiller) wrote :

Another note, in the last 2 years, Ubiquity has never booted correctly on this hardware so this problem is not something new. I never realized the issue was ubiquity until today. (Neon live booted on this laptop without requiring nomodeset and thus provided the ubiquity clue as Neon does not use ubiqutiy).

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1808657

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers