disco installer crashed with usr-merge

Bug #1801408 reported by Dimitri John Ledkov on 2018-11-02
186
This bug affects 21 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Status tracked in Disco
Disco
Critical
Unassigned

Bug Description

disco installer crashed

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: ubiquity 18.10.12
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
ApportVersion: 2.20.10-0ubuntu14
Architecture: amd64
CasperVersion: 1.399
CurrentDesktop: ubuntu:GNOME
Date: Fri Nov 2 19:28:27 2018
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd quiet splash --- maybe-ubiquity
LiveMediaBuild: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20181102)
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 LC_NUMERIC=C.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Dimitri John Ledkov (xnox) wrote :
Dimitri John Ledkov (xnox) wrote :

Nov 2 19:27:57 ubuntu /plugininstall.py: Exception during installation:
Nov 2 19:27:57 ubuntu /plugininstall.py: Traceback (most recent call last):
Nov 2 19:27:57 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1718, in <module>
Nov 2 19:27:57 ubuntu /plugininstall.py: install.run()
Nov 2 19:27:57 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 61, in wrapper
Nov 2 19:27:57 ubuntu /plugininstall.py: func(self)
Nov 2 19:27:57 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 178, in run
Nov 2 19:27:57 ubuntu /plugininstall.py: self.configure_python()
Nov 2 19:27:57 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 364, in configure_python
Nov 2 19:27:57 ubuntu /plugininstall.py: install_misc.chroot_setup(self.target)
Nov 2 19:27:57 ubuntu /plugininstall.py: File "/usr/lib/ubiquity/ubiquity/install_misc.py", line 137, in chroot_setup
Nov 2 19:27:57 ubuntu /plugininstall.py: with open(start_stop_daemon, 'w') as f:
Nov 2 19:27:57 ubuntu /plugininstall.py: FileNotFoundError: [Errno 2] No such file or directory: '/target/sbin/start-stop-daemon'

looking at /target/

It has libx32, lib64, lib32 symlinks to usr/* but not /bin or /sbin links to /usr/bin and /usr/sbin

summary: - disco installer crashed
+ disco installer crashed with usr-merge
tags: added: usrmerge
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2018-11-02
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
vmc (vmclark) wrote :

My crashed stated:

FileNotFoundError:
[Errno2] No such file or directory: '/target/sbin/start-stop-daemon'

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1801408

tags: added: iso-testing
tags: added: rls-dd-incoming

also with Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20181104)

Changed in ubiquity (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 19.04.1

---------------
ubiquity (19.04.1) disco; urgency=medium

  * Update d-i sources to point at disco
  * Automatic update of included source packages: choose-mirror
    2.78ubuntu5, preseed 1.71ubuntu9.
  * Support usr-merge in install.py. LP: #1801408

 -- Dimitri John Ledkov <email address hidden> Tue, 06 Nov 2018 18:25:22 +0000

Changed in ubiquity (Ubuntu Disco):
status: In Progress → Fix Released
vmc (vmclark) wrote :

Still fails installing current Xubuntu:

 disco-desktop-amd64.iso 2018-11-07 02:42

vmc (vmclark) wrote :

xubuntu md5sum: 8496e3986821cb895fc9ed0b202edaf9 fails to install

Jeremy Bicha (jbicha) wrote :

vmc, please try tomorrow's ISO. The fixed ubiquity version wasn't released in time for today's Xubuntu iso build.

You can see the specific ubiquity version if you look in the .manifest file provided in the same directory as the ISO.

http://cdimage.ubuntu.com/xubuntu/daily-live/current/

vmc (vmclark) wrote :

Jeremy, Thanks! Its reported that its been fixed. I guess I thought Ubuntu & Xubuntu shared the same Ubiquity with different proceeds.

Appreciate the feedback. I suspected as much. I did not see the failure in
any of the other daily builds.

Thanks

Gene

On Wed, Nov 7, 2018 at 2:56 PM Jeremy Bicha <email address hidden> wrote:

> vmc, please try tomorrow's ISO. The fixed ubiquity version wasn't
> released in time for today's Xubuntu iso build.
>
> You can see the specific ubiquity version if you look in the .manifest
> file provided in the same directory as the ISO.
>
> http://cdimage.ubuntu.com/xubuntu/daily-live/current/
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1801639).
> https://bugs.launchpad.net/bugs/1801408
>
> Title:
> disco installer crashed with usr-merge
>
> Status in ubiquity package in Ubuntu:
> Fix Released
> Status in ubiquity source package in Disco:
> Fix Released
>
> Bug description:
> disco installer crashed
>
> ProblemType: Bug
> DistroRelease: Ubuntu 19.04
> Package: ubiquity 18.10.12
> ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
> Uname: Linux 4.18.0-10-generic x86_64
> ApportVersion: 2.20.10-0ubuntu14
> Architecture: amd64
> CasperVersion: 1.399
> CurrentDesktop: ubuntu:GNOME
> Date: Fri Nov 2 19:28:27 2018
> InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper
> initrd=/casper/initrd quiet splash --- maybe-ubiquity
> LiveMediaBuild: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20181102)
> ProcEnviron:
> LANGUAGE=en_GB.UTF-8
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_GB.UTF-8
> LC_NUMERIC=C.UTF-8
> SourcePackage: ubiquity
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1801408/+subscriptions
>

vmc (vmclark) wrote :

Xubuntu is now fixed using current ISO:
 disco-desktop-amd64.iso 2018-11-08 02:22

To post a comment you must log in.