Installer crashed on the "Who Are You?" panel.

Bug #1798005 reported by Darin Miller on 2018-10-16
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Iain Lane

Bug Description

Tried install twice. Manual partition setup using existing partitions for root and home-selecting format for both. After selecting the timezone, the "Who Are you?" panel appears and the installer crashes immediately.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: ubiquity 18.10.10
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
CasperVersion: 1.399
CurrentDesktop: KDE
Date: Mon Oct 15 20:48:27 2018
InstallCmdLine: file=/cdrom/preseed/kubuntu.seed boot=casper maybe-ubiquity initrd=/casper/initrd quiet splash --- maybe-ubiquity
LiveMediaBuild: Kubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 (20181016)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Darin Miller (darinmiller) wrote :
Darin Miller (darinmiller) wrote :

Update: If I pause for a minute or so before proceeding to "Who are you panel?", the install proceeds without issue. Without the pause, maybe installer is attempting to write to drive that is not fully formatted?

Rik Mills (rikmills) wrote :

Crashlog

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
fossfreedom (fossfreedom) wrote :

Confirmed with today's Ubuntu Budgie ISO as well

Łukasz Zemczak (sil2100) wrote :

This is a known issue, a regression introduced by latest ubiquity changes, we are working on getting it fixed (or reverted).

Changed in ubiquity (Ubuntu):
importance: High → Critical
status: Confirmed → Triaged
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1798005

tags: added: iso-testing
Iain Lane (laney) wrote :

this https://git.launchpad.net/ubiquity/commit/?id=d784958 is our proposed fix, will upload it shortly

Changed in ubiquity (Ubuntu):
assignee: nobody → Iain Lane (laney)
status: Triaged → In Progress
Changed in ubiquity (Ubuntu):
status: In Progress → Fix Committed
APolihron (apolitech) wrote :

Ubuntu Mate has the same problem sadly. Thanks for the fix.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 18.10.11

---------------
ubiquity (18.10.11) cosmic; urgency=medium

  * kde, gtk: Wait for both timezone and partman_commit before installing.
    We were racing starting the installation with committing the partition
    table changes, if you were fast enough at the timezone selection page.
    What we need to do is wait until both timezone selection *and*
    partman_commit have finished before.
    This is a little bit delicate, because the user setup page, which comes
    after the timezone page, writes to debconf and so we have to be careful
    not to restart it after the user setup page is shown. We do that after
    finishing timezone selection, since this writes to debconf. It is not
    needed after partman_commit, because it only reads. (LP: #1798005)

 -- Iain Lane <email address hidden> Tue, 16 Oct 2018 12:33:12 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Rik Mills (rikmills) wrote :

Tested in vbox, proceeding as fast as I could.

Went past the crash point ok, install completed, and on restart the installed system has my -en-gb package present (which was what the regression causing change was intended to fix).

Thank you @Laney and sil2100.

Darin Miller (darinmiller) wrote :

Testing the 20181017 daily ISO, fix verified on the hardware used when bug was discovered; install worked perfectly this time.

Thanks for the fast fix!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers