Wrong keyboard layout is preselected

Bug #1783326 reported by Jean-Baptiste Lallement on 2018-07-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned
Bionic
Critical
Łukasz Zemczak

Bug Description

Ubuntu Bionic Desktop 20180724

Test Case
1. Start ubiquity from a live session or boot in 'Install Ubuntu' mode
2. Select 'French' as language
3. Press continue

Expected Result
French keyboard layout is selected

Actual Result
Afghan is selected (First on the list)

It works fine with the release image.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubiquity 18.04.14.5
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.3
Architecture: amd64
CasperVersion: 1.394
CurrentDesktop: ubuntu:GNOME
Date: Tue Jul 24 12:13:20 2018
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd ---
LiveMediaBuild: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180724)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Changed in ubiquity (Ubuntu Bionic):
milestone: none → ubuntu-18.04.1
importance: Undecided → High
importance: High → Critical
summary: - Wrong keyboard layout is preselected in only-ubiquity mode
+ Wrong keyboard layout is preselected
description: updated
Changed in ubiquity (Ubuntu Bionic):
assignee: nobody → Łukasz Zemczak (sil2100)
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1783326

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu Bionic):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
status: New → Confirmed

The verification of the Stable Release Update for console-setup has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Adam Conrad (adconrad) wrote :

This was fixed by rebuilding ubiquity against a reverted console-setup.

Changed in ubiquity (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers