ubiquity crashed with dbus.exceptions.DBusException in call_blocking(): org.freedesktop.DBus.Error.UnknownMethod: No such interface '(null)' on object at path /org/gnome/SessionManager

Bug #1766811 reported by Jean-Baptiste Lallement on 2018-04-25
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Unassigned
Bionic
Critical
Unassigned

Bug Description

Ubuntu Bionic Desktop 20180425

Default installation, this crash happens when the user presses on 'Restart' in the dialog at the end of installation.

It only happens in the live session but not in ubiquity-only mode.

ProblemType: Crash
DistroRelease: Ubuntu 18.04
Package: ubiquity 18.04.11
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CasperVersion: 1.393
Date: Wed Apr 25 09:00:15 2018
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
ExecutableTimestamp: 1524583775
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz maybe-ubiquity --- keyboard-configuration/layoutcode=fr keyboard-configuration/variantcode=oss
InterpreterPath: /usr/bin/python3.6
LiveMediaBuild: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180425)
ProcCmdline: /usr/bin/python3 /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcCwd: /home/ubuntu
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/5248/environ'
Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
SourcePackage: ubiquity
Title: ubiquity crashed with dbus.exceptions.DBusException in call_blocking(): org.freedesktop.DBus.Error.UnknownMethod: No such interface '(null)' on object at path /org/gnome/SessionManager
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

Jean-Baptiste Lallement (jibel) wrote :
information type: Private → Public
Changed in ubiquity (Ubuntu Bionic):
importance: Undecided → Critical
tags: removed: need-duplicate-check
Jean-Baptiste Lallement (jibel) wrote :

diff between 24 and 25

description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1766811

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 18.04.12

---------------
ubiquity (18.04.12) bionic; urgency=medium

  [ Didier Roche ]
  * Request shutdown and reboot without using gnome-session (LP: #1766811)
    The if gnome_session code path doesn't declare the GNOME
    session interface it's using, so don't work.
    Even fixing it, we notice that calls aren't wired in GNOME session code.
    Fallback thus for now to old code path which is executed at least
    since xenial (when DBUS address wasn't correct in ubiquity process)

  [ Iain Lane ]
  * The dbus import is now unused and is triggering a pyflakes error, but
    we're not sure it isn't initialising some state that's required. At this
    late stage, just silence the error.
  * Automatic update of included source packages: flash-kernel
    3.90ubuntu2.

 -- Didier Roche <email address hidden> Wed, 25 Apr 2018 10:33:57 +0100

Changed in ubiquity (Ubuntu Bionic):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers