Do not run gnome-initial-setup during OEM preparation stage

Bug #1765651 reported by Jean-Baptiste Lallement on 2018-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Jean-Baptiste Lallement
Bionic
High
Jean-Baptiste Lallement

Bug Description

During an OEM installation, gnome-initial-setup must not run in OEM preparation mode. Besides it asks question that are not relevant to this mode like the user name and the password.

There are several ways to determine if we are running an OEM session:
- Current user is 'oem'
- It is set to log in automatocally
- /home/oem/Desktop/oem-config-prepare-gtk.desktop exists

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-initial-setup 3.28.0-2ubuntu6
ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
Uname: Linux 4.15.0-15-generic x86_64
ApportVersion: 2.20.9-0ubuntu5
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Apr 20 11:37:37 2018
InstallationDate: Installed on 2014-07-15 (1375 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140520)
SourcePackage: gnome-initial-setup
UpgradeStatus: Upgraded to bionic on 2018-03-24 (26 days ago)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Changed in gnome-initial-setup (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-18.04
Iain Lane (laney) wrote :

I suspect fixing bug #1765644 would fix this too.

Changed in gnome-initial-setup (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
description: updated
affects: gnome-initial-setup (Ubuntu Bionic) → ubiquity (Ubuntu Bionic)
Changed in ubiquity (Ubuntu Bionic):
assignee: Robert Ancell (robert-ancell) → Jean-Baptiste Lallement (jibel)
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1765651

tags: added: iso-testing
Changed in ubiquity (Ubuntu Bionic):
status: Triaged → In Progress
Changed in ubiquity (Ubuntu Bionic):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 18.04.10

---------------
ubiquity (18.04.10) bionic; urgency=medium

  [ Colin Watson ]
  * Update translations from Launchpad.

  [ Simon Quigley ]
  * Following the lead of the GTK frontend, remove the encrypted home
    directory option from the Qt installer since ecryptfs no longer has
    support from the Ubuntu Security Team. This removes the frontend but keeps
    the codebase for the option so it can be added back later using another
    technology (LP: #1761396).

  [ Adam Conrad ]
  * Automatic update of included source packages: localechooser
    2.71ubuntu2.

  [ Jean-Baptiste Lallement ]
  * Do not start gnome-initial-setup for the OEM user (LP: #1765651)

 -- Adam Conrad <email address hidden> Mon, 23 Apr 2018 04:59:24 -0600

Changed in ubiquity (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers