[xubuntu, budgie & mate] ISO boots directly to desktop

Bug #1763739 reported by Kev Bowring on 2018-04-13
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Steve Langasek

Bug Description

Booting xubuntu live session from iso directly from grub menu.

I see no Try/Install dialogue instead I am booted directly to the live desktop.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubiquity 18.04.5
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
ApportVersion: 2.20.9-0ubuntu4
Architecture: amd64
CasperVersion: 1.393
CurrentDesktop: XFCE
Date: Fri Apr 13 14:36:46 2018
InstallCmdLine: BOOT_IMAGE=(loop)/casper/vmlinuz.efi boot=casper iso-scan/filename=/boot/grubiso/xubuntu-bionic-desktop-amd64.iso noprompt noswap noeject
LiveMediaBuild: Xubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180413)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Kev Bowring (flocculant) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1763739

tags: added: iso-testing

Same issue happens when using qemu/kvm - however here I do actually see the Try/Install dialogue appear fleetingly - I assume that if I wasn't using SSD and booting directly from the iso rather than a usb - I would fleetingly see the dialogue there.

summary: - USb boots directly to desktop
+ ISO boots directly to desktop

On 13/04/18 16:05, Ubuntu QA Website wrote:
> This bug has been reported on the Ubuntu ISO testing tracker.
>
> A list of all reports related to this bug can be found here:
> http://iso.qa.ubuntu.com/qatracker/reports/bugs/1763739
>
> ** Tags added: iso-testing
>
Checked the following iso's:

Budgie from 12/4 - looks to hang about at a login prompt, then boots to
desktop.
Mate from 13/4 - looks to hang about at a login prompt, then boots to
desktop.

Ubuntu from 9/4 - boots to Try/Install Dialogue

Lubuntu doesn't appear to use that dialogue - choice of try and install
at the first menu for that iso.

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
David Pearson (akxwi-dave) wrote :

Happening on 32bit iso as well.. as of 18/04/2018

David Pearson (akxwi-dave) wrote :

on x64 version, I see a flash of the try or install screen before it goes straight to desktop..

Jean-Baptiste Lallement (jibel) wrote :

This is the error

[ 30.686858] xubuntu ubiquity[1497]: Ubiquity 18.04.6
[ 31.948744] xubuntu ubiquity[1497]: Exception in GTK frontend (invoking crash handler):
[ 31.949300] xubuntu ubiquity[1497]: Traceback (most recent call last):
[ 31.949525] xubuntu ubiquity[1497]: File "/usr/lib/ubiquity/bin/ubiquity", line 655, in <module>
[ 31.949672] xubuntu ubiquity[1497]: main(oem_config)
[ 31.949796] xubuntu ubiquity[1497]: File "/usr/lib/ubiquity/bin/ubiquity", line 641, in main
[ 31.949919] xubuntu ubiquity[1497]: install(query=options.query)
[ 31.950028] xubuntu ubiquity[1497]: File "/usr/lib/ubiquity/bin/ubiquity", line 270, in install
[ 31.950134] xubuntu ubiquity[1497]: wizard = ui.Wizard(distro)
[ 31.950241] xubuntu ubiquity[1497]: File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 239, in __init__
[ 31.950353] xubuntu ubiquity[1497]: self.watch = Gdk.Cursor.new(Gdk.CursorType.WATCH)
[ 31.950464] xubuntu ubiquity[1497]: TypeError: constructor returned NULL
[ 31.950577] xubuntu ubiquity[1497]:
[ 32.127465] xubuntu ubiquity[1519]: Unable to init server: Could not connect: Connection refused
[ 32.163088] xubuntu ubiquity[1519]: Unable to init server: Could not connect: Connection refused

Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
tags: added: rls-bb-incoming
Jean-Baptiste Lallement (jibel) wrote :

and the traps just before this trace

[ 28.900976] xubuntu kernel: traps: xfsettingsd[1491] trap int3 ip:7f8a4f9dfc41 sp:7fff2ddeac90 error:0 in libglib-2.0.so.0.5600.1[7f8a4f98e0

actually this trap is just because it cannot open a display

journal with the failure.

Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
Kev Bowring (flocculant) wrote :

@jibel - as far as I'm aware there is a merge from Steve Langasek for this? at least that was my impression when talking to him - https://bazaar.launchpad.net/~vorlon/ubiquity/conflict-with-getty1/revision/6609

summary: - ISO boots directly to desktop
+ [xubuntu] ISO boots directly to desktop
Kev Bowring (flocculant) on 2018-04-18
summary: - [xubuntu] ISO boots directly to desktop
+ [xubuntu, budgie & mate] ISO boots directly to desktop
Steve Langasek (vorlon) wrote :

This was fixed in ubiquity 18.04.6.

ubiquity (18.04.6) bionic; urgency=medium

  [ Steve Langasek ]
  * If we are running ubiquity-dm on VT1, we must conflict with
    <email address hidden> and not rely on some other display manager to do
    this for us.

  [ Brian Murray ]
  * Drop the option to upgrade from an old release using ubiquity as it is
    crashing and leaves users in a broken state. (LP: #1756862)

  [ litianzhi ]
  * Fix untranslated "This software is subject to license" (LP: #1762097)

  [ Mathieu Trudel-Lapierre ]
  * debian/real-po/, po/: Translations import from Launchpad.

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

jibel's logs show that this is still happening with ubiquity 18.04.6. reopening for another look.

Changed in ubiquity (Ubuntu):
status: Fix Released → Triaged
Steve Langasek (vorlon) wrote :

The correct service name to conflict with is '<email address hidden>', not '<email address hidden>'. Fixing.

Changed in ubiquity (Ubuntu):
status: Triaged → In Progress
assignee: Ubuntu Installer Team (ubuntu-installer) → Steve Langasek (vorlon)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 18.04.7

---------------
ubiquity (18.04.7) bionic; urgency=medium

  * The correct service name to conflict with is <email address hidden>, not
    <email address hidden>. LP: #1763739.

 -- Steve Langasek <email address hidden> Wed, 18 Apr 2018 18:09:53 -0700

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers