ubuntu installations in Kenya are problematic because default language is little known Oromo, not English or Swahili

Bug #1763025 reported by Alex GOOD HEARTS Organisation on 2018-04-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
localechooser (Debian)
New
Unknown
ubiquity (Ubuntu)
Low
Gunnar Hjalmarsson

Bug Description

even on a fresh install and since many may years, despite even Debian Bug reports - e.g. #756277:

There is an error with locale information for Kenya in ubuntu installation. Language is automatically set to 'Oromo' (understood only by a 3% minority of Ethiopian descent) yet the official languages in Kenya are (the not selectable) en-KE (somehow British English, Kenyan flavour, paper format A4, currency KES, currency format KES 123,456.00 or 123,456/= ) and (the also not selectable) sw-KE (somehow Swahili, Kenyan flavour, paper format A4, currency KES, currency format KES 123,456.00 or 123,456/= )

>>> please make work both locales, en-KE (default) and sw-KE. (Remove Oromo from Kenyan locales)

Jeremy Bicha (jbicha) on 2018-04-11
affects: gnome-shell (Ubuntu) → ubuntu-translations
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report. It's worth looking into, but it won't be fixed for Ubuntu 18.04.

However, as regards *language* there are no translations available for neither the Kenyan flavor of English nor Swahili, so the most reasonable choice is probably English (UK) which is selectable by default.

As regards *formats*, i.e. the setting for date and number formats, currency etc., you can generate the sw_KE locale with this command:

sudo locale-gen sw_KE

That will make Kenya selectable under Formats at next login.

affects: ubuntu-translations → localechooser (Ubuntu)
Changed in localechooser (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in localechooser (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2020-07-24
Changed in localechooser (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
affects: localechooser (Ubuntu) → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 20.10.12

---------------
ubiquity (20.10.12) groovy; urgency=medium

  [ Gunnar Hjalmarsson ]
  * d-i/patches/localechooser-post-base-installer.patch:
    - Set sw (Swahili) as the default Kenya language (LP: #1763025)
  * Translation update (LP: #1897444)

  [ Sebastien Bacher ]
  * POTFILES.in entries were not updated after a directory rename

 -- Gunnar Hjalmarsson <email address hidden> Fri, 16 Oct 2020 11:41:38 +0100

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.