[ffe] Optional recording/sending of installer&system details to help improving Ubuntu

Bug #1755456 reported by Sebastien Bacher on 2018-03-13
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-initial-setup (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Unassigned
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Rationale]
We added telemetry data for people installing ubuntu from ubiquity. We didn't get the time to do the same on upgrade despite the FFe acking it. It was decided it was better to first polish the installation and report experience, and then, tackling the upgrade for .1, where most LTS users will migrate from.

ubuntu-release-upgrade just drop a telemetry file (like ubiquity is dropping one) which is then picked up by ubuntu-report for user's review and approval before sending.

Note that ubuntu-report is already aware of the upgrade telemetry and just ignores it when it's missing it (case of install of ugprade without this ubuntu-release-upgrade versinon)

[Impact]
 * ubuntu-release-upgrade just drop a telemetry file (like ubiquity is dropping one) which is then picked up by ubuntu-report for user's review and approval before sending.
 * Note that ubuntu-report is already aware of the upgrade telemetry and just ignores it when it's missing it (case of install of ugprade without this ubuntu-release-upgrade versinon)
 * The ubuntu-release-upgrade only drops a file thus. The logic is really similar to the one included in ubiquity for 18.04. The telemetry class is similar.
 * The telemetry is reported by all existing UI.
 * What we send is:
   - From (distro we ugprade from)
   - Type of installer (GTK, KDE, non interactive, text…)
   - If third party ressources were used (but not the list of those external repos)
   - Original installation media
   - Stages of installation indexed by their relative time duration

[Test Case]
 * Install ubuntu-release-upgrade on an artful machine
 * Run an upgrade from artful to bionic
 * Check that once the upgrade finished, there is a /var/log/ugprade/telemetry file present on disk.

[Regression Potential]

 * The code is similar to ubiquity ones, and the impact is only dropping a file on disk.
 * Preliminary testing has been done on 17.04 -> 18.04 upgrade, in text mode, GTK3 and KDE frontends.

---------------

The topic has been discussed on the ubuntu-devel@ list, see https://lists.ubuntu.com/archives/ubuntu-devel/2018-February/040139.html

The feature has different parts
- the installer is going to record some informations about the installation details & options selected
- the session is going to have a command line/GUI part that let user review&send those informations
- the desktop settings should have a control to change the option later on

Related branches

Didier Roche (didrocks) wrote :

The impacted components are:
- ubiquity (ready to upload as of 28/03)
- ubuntu-report (a CLI and C bindings, new package ready to upload as of 28.03)
- GUI part using this C binding is a fork of gnome-initial-setup, with different panels for livepatch and others. One of the panel is this telemetry option. WIP by Robert Ancell.
- do-release-upgrade, which will optionally (as ubiquity) reports upgrade metrics. WIP, can happen later as it only drops a file on disk which is no impact if not present.

Desktop settings in gnome-control-center will be added once gnome-initial-setup will change those options and will be another FFe/UIFe.

Łukasz Zemczak (sil2100) wrote :

FFe and UIFe for this approved but please make sure to land everything as soon as possible. We are already a week after string freeze and the new strings that will get introduced here really should be translated for release. Also, be sure to send out a notice to the translation and documentation teams about this!

Changed in ubiquity (Ubuntu):
status: New → Triaged
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Triaged
Łukasz Zemczak (sil2100) wrote :

Would also be nice if we could get most of the user-facing required changes released before Final Beta, for it to get some wider testing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 18.04.4

---------------
ubiquity (18.04.4) bionic; urgency=medium

  [ Mathieu Trudel-Lapierre ]
  * debian/control: have ubiquity-frontend-gtk Depends: explicitly on
    sensible-utils, which is used to start a browser when slideshow or
    release notes links are clicked. (LP: #1724224)
  * Automatic update of included source packages: netcfg 1.142ubuntu6,
    partman-efi 71ubuntu2, user-setup 1.63ubuntu5.

  [ Sebastien Bacher ]
  * gui/gtk/stepPrepare.ui: updated the non-free-software text to not
    include the mention to the MP3 fluendo codecs since those have
    been superseeded in the recent gstreamer version.
  * Rename the "Preparing to install Ubuntu" installer step to "Updates and
    other software" according to the design, thanks Matthew for pointing
    out the inconsistency

  [ Didier Roche ]
  * Collect and dump telemetry info as a log file: (LP: #1755456)
    Those installation telemetry info are for optional upload later on.

  [ Jeremy Bicha ]
  * Update "Updates and Other Software" page to match the spec (LP: #1758082)

  [ Rik Mills ]
  * Update KDE/Qt "Updates and Other Software" page in line with GTK changes,
    with some tweaks appropriate for Kubuntu usage in Bionic
  * Mark the sddm.conf file for OEM so that it can be removed by oem-config
    if unchanged.

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 29 Mar 2018 13:42:51 -0400

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
Iain Lane (laney) on 2018-04-06
Changed in gnome-initial-setup (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.28.0-2ubuntu1

---------------
gnome-initial-setup (3.28.0-2ubuntu1) bionic; urgency=medium

  * debian/patches/0001-Add-Ubuntu-mode-with-special-pages.patch:
  * debian/ubuntu-changes.png:
    - Show Ubuntu welcome pages (LP: #1755456)
  * debian/control:
    - Build-Depends on libsnapd-glib-dev, libsoupd2.4-dev,
      libsysmetrics-dev
    - Enable langpack usage

 -- Robert Ancell <email address hidden> Fri, 06 Apr 2018 09:52:39 +1200

Changed in gnome-initial-setup (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2018-04-17
Changed in ubuntu-meta (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.417

---------------
ubuntu-meta (1.417) bionic; urgency=medium

  * Refreshed dependencies
  * Added gnome-initial-setup and ubuntu-report to desktop-recommends
    (LP: #1755456)

 -- Didier Roche <email address hidden> Wed, 18 Apr 2018 15:16:07 +0200

Changed in ubuntu-meta (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2018-05-29
description: updated
Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: New → Triaged
no longer affects: ubuntu-meta (Ubuntu Bionic)
no longer affects: ubiquity (Ubuntu Bionic)
no longer affects: gnome-initial-setup (Ubuntu Bionic)
Didier Roche (didrocks) on 2018-05-29
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.10.2

---------------
ubuntu-release-upgrader (1:18.10.2) cosmic; urgency=medium

  * Add upgrade telemetry information (LP: #1755456)
  * Updated translations

 -- Didier Roche <email address hidden> Tue, 29 May 2018 15:15:45 +0200

Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Fix Released

Hello Sebastien, or anyone else affected,

Accepted ubuntu-release-upgrader into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:18.04.19 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Didier Roche (didrocks) wrote :

Done upgrade testing, and everything is as expected.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.04.19

---------------
ubuntu-release-upgrader (1:18.04.19) bionic; urgency=medium

  * Add upgrade telemetry information (LP: #1755456)
  * Updated translations

 -- Didier Roche <email address hidden> Thu, 03 May 2018 15:55:34 +0200

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers