ubiquity crashes in start_slideshow - Could not locate webkit_web_context_get_default: 'webkit_web_context_get_default': /usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-4.0.so.18: undefined symbol: webkit_web_context_get_default

Bug #1752535 reported by errors.ubuntu.com bug bridge on 2018-03-01
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
webkit2gtk (Ubuntu)
Undecided
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding ubiquity. This problem was most recently seen with package version 18.04.2, the problem page at https://errors.ubuntu.com/problem/f8cb12490c4fbefafd401bb31ee43efc0166b8cc contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Traceback (most recent call last):
  File "/usr/lib/ubiquity/bin/ubiquity", line 655, in <module>
    main(oem_config)
  File "/usr/lib/ubiquity/bin/ubiquity", line 641, in main
    install(query=options.query)
  File "/usr/lib/ubiquity/bin/ubiquity", line 274, in install
    ret = wizard.run()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 818, in run
    self.start_slideshow()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 898, in start_slideshow
    context = WebKit2.WebContext.get_default()
GLib.GError: g-invoke-error-quark: Could not locate webkit_web_context_get_default: 'webkit_web_context_get_default': /usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-4.0.so.18: undefined symbol: webkit_web_context_get_default (1)

summary: - /usr/lib/ubiquity/bin/ubiquity:GLib.GError:/usr/lib/ubiquity/bin/ubiquity@655:main:install:run:start_slideshow
+ ubiquity crashes in start_slideshow - Could not locate
+ webkit_web_context_get_default: 'webkit_web_context_get_default':
+ /usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-4.0.so.18: undefined
+ symbol: webkit_web_context_get_default
description: updated
Jean-Baptiste Lallement (jibel) wrote :

From errors.u.c it started on Feb 27th on Bionic.

affects: webkit (Ubuntu) → webkit2gtk (Ubuntu)
Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webkit2gtk (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

The issue there is

Failed to load shared library 'libwebkit2gtk-4.0.so.37' referenced by the typelib: libGL.so.1: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога

so libGL seems to be missing from the system

Georgi Boiko (pandasauce) wrote :

How is this not listed under bionic? It is currently impossible to install daily image because of this bug - the installer crashes.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers