ubiquity crashed with UnicodeDecodeError in decode(): 'utf-8' codec can't decode byte 0x91 in position 269: invalid start byte

Bug #1740026 reported by Giovanni Preda on 2017-12-25
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Trying to install

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: ubiquity 17.10.10
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CasperVersion: 1.387
Date: Mon Dec 25 13:19:57 2017
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python3.6
LiveMediaBuild: Lubuntu 17.10 "Artful Aardvark" - Release amd64 (20171017.1)
ProcCmdline: /usr/bin/python3 /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron:
 TERM=unknown
 PATH=(custom, no user)
 LANG=C.UTF-8
 SHELL=/bin/bash
Python3Details: /usr/bin/python3.6, Python 3.6.3, python3-minimal, 3.6.3-0ubuntu2
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
PythonDetails: /root/Error: command ['which', 'python'] failed with exit code 1:, Error: [Errno 2] No such file or directory: "/root/Error: command ['which', 'python'] failed with exit code 1:": "/root/Error: command ['which', 'python'] failed with exit code 1:", unpackaged
SourcePackage: ubiquity
Title: ubiquity crashed with UnicodeDecodeError in decode(): 'utf-8' codec can't decode byte 0x91 in position 269: invalid start byte
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Giovanni Preda (preda-giovanni) wrote :
tags: removed: need-duplicate-check
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
information type: Private → Public
Giovanni Preda (preda-giovanni) wrote :

No one? This happens with every Ubuntu-based distro

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Could you please detail the steps to reproduce this crash? I tried with Lubuntu 17.10, Ubuntu 17.10 and 18.04 with Italian and cannot reproduce this bug.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Giovanni Preda (preda-giovanni) wrote :

This problem only occurs when I try to install an Ubuntu-based distro on my Teclast X80 Plus tablet (Intel Atom x5-Z8350, 2GB RAM, 32GB EMMC).
I also tried selecting another language (English) but nothing changed.
I can install Lubuntu without any problem using the alternate iso where the installation is not made in a live environment.
Installing via USB stick made with Rufus.
Thanks for your reply.

Giovanni Preda (preda-giovanni) wrote :

Sorry, I forgot to mention that I also tried with Ubuntu 16.04.3 LTS and I have the same problem.

Giovanni Preda (preda-giovanni) wrote :

Do someone need more informations?

Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers