"_Skip" button label not translatable

Bug #1731070 reported by AsciiWolf on 2017-11-08
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

The "Skip" string is showing as untranslated in non-English Ubuntu installation. This is because "Skip" is in the translation template, but "_Skip" is not. (See comment #7.)

Related branches

AsciiWolf (asciiwolf) on 2017-11-08
summary: - Translation is not applied for some strings
+ Translation is not applied for some strings in Ubiquity

Thank you for your bug report, what Ubuntu version are you testing?

AsciiWolf (asciiwolf) wrote :

As noted in the bug tags, I was testing it on Ubuntu 17.10, but the same issue is also present in Ubuntu 18.04.

AsciiWolf (asciiwolf) wrote :

The "This software is subject to license terms included with its documentation. Some is proprietary." string is still untranslated in the latest Ubuntu 18.04 Beta 2 although it is fully translated on Launchpad in my (Czech) language.

AsciiWolf (asciiwolf) wrote :

The "Skip" button is also untranslated although it is translated on Launchpad.

Gunnar Hjalmarsson (gunnarhj) wrote :

Is this possibly fixed now? This upload:

https://launchpad.net/ubuntu/+source/ubiquity/18.04.6

ought to have taken care of it.

Changed in ubuntu-translations:
status: New → Incomplete
Changed in ubiquity (Ubuntu):
status: New → Incomplete
AsciiWolf (asciiwolf) wrote :

Yep, it's fixed. :-)
But the "Skip" button (see comment #4) is still untranslated.

Gunnar Hjalmarsson (gunnarhj) wrote :

I see that "Skip" is in the template, but "_Skip" is not.

https://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk/view/head:/gui/gtk/ubiquity.ui#L1017

May be a hint. Can you please change the bug summary to focus on the remaining issue.

Changed in ubuntu-translations:
status: Incomplete → Confirmed
Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
AsciiWolf (asciiwolf) on 2018-04-21
description: updated
AsciiWolf (asciiwolf) wrote :

Feel free to close this issue when the "_Skip" string is added. I will update the Czech translation.

Gunnar Hjalmarsson (gunnarhj) wrote :

The remaining problem is that you can't, right? I changed the bug summary to reflect that.

summary: - Translation is not applied for some strings in Ubiquity
+ "_Skip" button label not translatable
AsciiWolf (asciiwolf) on 2018-05-01
description: updated
AsciiWolf (asciiwolf) wrote :

Any chance that this could be fixed before Ubuntu 18.04.1 release?

AsciiWolf (asciiwolf) wrote :

Still not fixed. :-(

Adolfo Jayme (fitojb) on 2019-01-18
Changed in ubuntu-translations:
importance: Undecided → Medium
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
AsciiWolf (asciiwolf) wrote :

The "_Skip" string is still missing in the translation template.

tags: removed: artful
AsciiWolf (asciiwolf) wrote :

Removed the bionic tag because this issue is not related only to Ubuntu 18.04 and is still not fixed in the latest nightly.

tags: removed: bionic
AsciiWolf (asciiwolf) wrote :

Still not fixed in 19.10.

Changed in ubiquity (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 19.10.19

---------------
ubiquity (19.10.19) eoan; urgency=medium

  [ Sebastien Bacher ]
  * Update the 'Skip' string to '_Skip', matching the change done to
    ubiquity.ui some years ago. The template needs to be manual updated which
    wasn't done at the time, should make it translatable again (LP: #1731070)

  [ Mathieu Trudel-Lapierre ]
  * Update translations from Launchpad.
  * debian/real-po/templates.pot: update template using debconf-updatepo.

  [ Jean-Baptiste Lallement ]
  * Switch zpool sync property back to standard after installation
  * zfsutils-linux and zfs-initramfs moved to the live task, don't remove them
    at the end of installation (LP: #1847739)
  * Change partition types to Solaris Boot and Root types

  [ Didier Roche ]
  * As we are not going to own in the end org.zsys, move our identifier tags
    to com.ubuntu.zsys (LP: #1847711)

 -- Jean-Baptiste Lallement <email address hidden> Fri, 11 Oct 2019 12:05:23 +0200

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments