"Force UEFI installation" dialog has non-working Go Back/Continue buttons

Bug #1724482 reported by Jean-Baptiste Lallement on 2017-10-18
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Test Case
1. On a UEFI system go to the custom partitioning page
2. Create a custom partition but don't create the uefi partition
3. Continue, and force the installation despite the warning message

Actual result
"Force UEFI installation" dialog has non-working Go Back/Continue buttons. The user can navigate and click both with kdb and mouse but actions have no effect.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: ubiquity 17.10.10
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CasperVersion: 1.387
CurrentDesktop: ubuntu:GNOME
Date: Wed Oct 18 08:06:42 2017
LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171017.1)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1724482

tags: added: iso-testing
Iain Lane (laney) wrote :

I tried a bit to look at this.

Note that when you continue the previous question ('partman/continue'), the installer moves on to the timezone page. I think that's part of the issue - this page can't handle the dialog. Also the question name ('partman-efi/non_efi_system') isn't matched by the list of expected questions, but I didn't find out yet if that's a problem because I don't know atm how to solve the first bit.

Changed in ubuntu-release-notes:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers