Activity log for bug #1724417

Date Who What changed Old value New value Message
2017-10-18 01:18:35 Mathieu Trudel-Lapierre bug added bug
2017-10-18 02:09:34 Ubuntu QA Website tags amd64 apport-bug artful amd64 apport-bug artful iso-testing
2017-10-19 10:28:11 Jean-Baptiste Lallement description This should not be happening at all. Install fails with a grub-install error; failing to find /dev/dm-0. Interestingly, I picked "Erase entire disk", for a system (Dell Vostro V130) that was previously installed with Xubuntu. Given that "Erase entire disk" should just wipe all partitions and create new ones, none of which using LVM (because that was not picked at all, neither LVM not LVM with crypto); it should not be trying to use dm-0 at all. There are other errors earlier on with ubiquity failing to properly recognize the type of filesystem. ProblemType: Bug DistroRelease: Ubuntu 17.10 Package: ubiquity 17.10.10 ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4 Uname: Linux 4.13.0-16-generic x86_64 ApportVersion: 2.20.7-0ubuntu3 Architecture: amd64 CasperVersion: 1.387 CurrentDesktop: ubuntu:GNOME Date: Tue Oct 17 21:14:21 2017 LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171017.1) ProcEnviron: TERM=xterm-256color PATH=(custom, no user) XDG_RUNTIME_DIR=<set> LANG=fr_FR.UTF-8 SHELL=/bin/bash SourcePackage: ubiquity UpgradeStatus: No upgrade log present (probably fresh install) This should not be happening at all. Install fails with a grub-install error; failing to find /dev/dm-0. Interestingly, I picked "Erase entire disk", for a system (Dell Vostro V130) that was previously installed with Xubuntu. Given that "Erase entire disk" should just wipe all partitions and create new ones, none of which using LVM (because that was not picked at all, neither LVM not LVM with crypto); it should not be trying to use dm-0 at all. There are other errors earlier on with ubiquity failing to properly recognize the type of filesystem. Test Case 1. Install a system using LVM (not encryted) and proceed with the installation 2. Install a second time on the same system but this time select "Erase entire disk" Expected result Second installation is successful Actual result grub-installer fails because it tries to install grub on /dev/dm-0 ProblemType: Bug DistroRelease: Ubuntu 17.10 Package: ubiquity 17.10.10 ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4 Uname: Linux 4.13.0-16-generic x86_64 ApportVersion: 2.20.7-0ubuntu3 Architecture: amd64 CasperVersion: 1.387 CurrentDesktop: ubuntu:GNOME Date: Tue Oct 17 21:14:21 2017 LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171017.1) ProcEnviron:  TERM=xterm-256color  PATH=(custom, no user)  XDG_RUNTIME_DIR=<set>  LANG=fr_FR.UTF-8  SHELL=/bin/bash SourcePackage: ubiquity UpgradeStatus: No upgrade log present (probably fresh install)
2017-10-19 10:28:54 Jean-Baptiste Lallement ubiquity (Ubuntu): importance Undecided High
2017-10-19 10:28:58 Jean-Baptiste Lallement ubiquity (Ubuntu): status New Confirmed
2017-10-19 12:11:48 Francis Ginther tags amd64 apport-bug artful iso-testing amd64 apport-bug artful id-59e7bcfce82483e3f1f4632b iso-testing
2017-10-22 02:15:16 Mathew Hodson bug task added ubuntu-release-notes
2017-10-22 02:15:23 Mathew Hodson ubuntu-release-notes: status New Fix Released
2017-10-23 08:08:24 Marc Evrard bug added subscriber Marc Evrard