installer gets time wrong

Bug #172439 reported by David Balažic on 2007-11-27
This bug report is a duplicate of:  Bug #97161: Time mismatch when hw clock is not UTC. Edit Remove
6
Affects Status Importance Assigned to Milestone
tzdata (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

(gutsy) Ubuntu desktop i386 CD

In the install wizard, on the "Where are you?" page, the time is not displayed correctly on some PCs I tried.

wall clock : 20:15
hw clock : 20:15

 - boot the CD (default boot menu item)
 - on dekstop, start the install
 - on 1. page, click NEXT (english is selected by default)
 - on the 2. page ("Where are you?"), select the time zone "Ljubljana (Slovenia)" (north-east of Italy on the map)
Expected result :
time in the install wizard dialog is displayed as 8:15 PM

actual result:
 - on a HP nw8440 laptop : 9:15 PM (wrong)
 - an PC (Athlon 1400) : 8:15 PM (correct)
 - vmware running on the Athlon 1400 PC : 9:15 PM (wrong)

SK (stephantom) wrote :

Could this be the result of an outdated tz-data package?

David Balažic (xerces8) wrote :

I tried 8.04 alpha3 and it appears to works correctly.
But previously I noticed that is sometimes works, sometimes not.

This is really not hard to test, so please ...
(you just have to select any timezone and check that the time displayed matches the BIOS clock, which also matches the real clock)
(also check system time: date -u)
(if the BIOS clock happens to be UTC, which is rare IMO, then the above does not apply; if you run the BIOS clock in UTC, then you probably don't need my help to figure out if ubuntu gets the time correctly or not ;-) )

TerryG (tgalati4) wrote :

Triaged to Fixed Committed. Reporter states that it is fixed in 8.04 Alpha. Hope it continues to work in Hardy final release.

Changed in ubiquity:
status: New → Fix Released
David Balažic (xerces8) wrote :

It does not.
In 8.04 beta (desktop i386) it is wrong again.

 - boot (first boot menu item)
 - start "Install" icon on desktop
 - on page "Where are you ?" select Ljubljana (CET)

It shows the time one hour ahead (16:10 instead of correct 15:10; wall clock is 15:10, HW clock is 15:10).

Changed in ubiquity:
status: Fix Released → Confirmed
Nicolò Chieffo (yelo3) wrote :

9.04 final: same problem.

In my opinion this is related to the fact that the installer thinks that my time is UTC; so it is 'translated' to my timezone: which is +1 during autumn/winter and +2 during spring/summer

In fact, depending on when I install, I see the time increased by 1 or 2 hours

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers