ubiquity crashed with FileNotFoundError in _execute_child(): [Errno 2] No such file or directory: 'sensible-browser': 'sensible-browser'

Bug #1724224 reported by Jean-Baptiste Lallement on 2017-10-17
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned
ubuntu-meta (Ubuntu)
Critical
Adam Conrad
ubuntu-release-upgrader (Ubuntu)
Low
Brian Murray

Bug Description

Test Case
1. Boot to the live session
2. Start the installer
3. Click on the release notes link.

Expected result
A webbrowser opens with the release notes

Actual result
This crash

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: ubiquity 17.10.10
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CasperVersion: 1.387
Date: Tue Oct 17 11:36:00 2017
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
ExecutableTimestamp: 1507903384
InterpreterPath: /usr/bin/python3.6
LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171017)
ProcCmdline: /usr/bin/python3 /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcCwd: /home/ubuntu
ProcEnviron:
 TERM=unknown
 PATH=(custom, no user)
 LANG=C.UTF-8
 SHELL=/bin/bash
Python3Details: /usr/bin/python3.6, Python 3.6.3, python3-minimal, 3.6.3-0ubuntu2
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
PythonDetails: /usr/bin/python2.7, Python 2.7.14, python-minimal, 2.7.14-2ubuntu1
SourcePackage: ubiquity
Title: ubiquity crashed with FileNotFoundError in _execute_child(): [Errno 2] No such file or directory: 'sensible-browser': 'sensible-browser'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Jean-Baptiste Lallement (jibel) wrote :
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
tags: removed: need-duplicate-check
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1724224

tags: added: iso-testing
Adam Conrad (adconrad) wrote :

ubiquity (and probably dozens of other things) should depend on sensible-utils. That said, it used to be transitively Essential, and I'm currently yanking it back into required to patch over the icky for artful. Will give this a bit of rethink for BB.

Changed in ubiquity (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
assignee: Adam Conrad (adconrad) → nobody
Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Changed in ubiquity (Ubuntu):
importance: Critical → Medium
Changed in ubuntu-meta (Ubuntu):
importance: Undecided → Critical
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.404

---------------
ubuntu-meta (1.404) artful; urgency=medium

  * Refreshed dependencies
  * Added sensible-utils to minimal (LP: #1724224)

 -- Adam Conrad <email address hidden> Tue, 17 Oct 2017 06:51:03 -0600

Changed in ubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Triaged
importance: Undecided → Low
tags: added: rls-bb-incoming
Changed in ubiquity (Ubuntu):
status: Triaged → Invalid
Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.04.9

---------------
ubuntu-release-upgrader (1:18.04.9) bionic; urgency=medium

  [ Balint Reczey ]
  * Place .keep files in empty directories to keep them when converting the
    repo to git
  * Raise privileges in do-partial-upgrade early with pkexec and apply
    Wayland workaround when needed (LP: #1748509)

  [ Brian Murray ]
  * debian/control: have python3-distupgrade depend on sensible-utils.
    (LP: #1724224)
  * DistUpgrade/DistUpgradeController.py: In a couple of spots roll back
    changes made for the upgrade instead of just exiting.

 -- Brian Murray <email address hidden> Thu, 22 Feb 2018 13:43:35 -0800

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
Changed in ubiquity (Ubuntu):
status: Invalid → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 18.04.4

---------------
ubiquity (18.04.4) bionic; urgency=medium

  [ Mathieu Trudel-Lapierre ]
  * debian/control: have ubiquity-frontend-gtk Depends: explicitly on
    sensible-utils, which is used to start a browser when slideshow or
    release notes links are clicked. (LP: #1724224)
  * Automatic update of included source packages: netcfg 1.142ubuntu6,
    partman-efi 71ubuntu2, user-setup 1.63ubuntu5.

  [ Sebastien Bacher ]
  * gui/gtk/stepPrepare.ui: updated the non-free-software text to not
    include the mention to the MP3 fluendo codecs since those have
    been superseeded in the recent gstreamer version.
  * Rename the "Preparing to install Ubuntu" installer step to "Updates and
    other software" according to the design, thanks Matthew for pointing
    out the inconsistency

  [ Didier Roche ]
  * Collect and dump telemetry info as a log file: (LP: #1755456)
    Those installation telemetry info are for optional upload later on.

  [ Jeremy Bicha ]
  * Update "Updates and Other Software" page to match the spec (LP: #1758082)

  [ Rik Mills ]
  * Update KDE/Qt "Updates and Other Software" page in line with GTK changes,
    with some tweaks appropriate for Kubuntu usage in Bionic
  * Mark the sddm.conf file for OEM so that it can be removed by oem-config
    if unchanged.

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 29 Mar 2018 13:42:51 -0400

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers