using "ana" as password, the installation failed on plugininstall.py

Bug #1718317 reported by joseph on 2017-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

I crested a custom ISO , when the user use a weak password , for example: "ana" , after some minutes the installation crash on plugininstall.py ubiquity.install_misc.installStepError: plugin usersetup failed with code 1

attached logs

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.63.2
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
NonfreeKernelModules: symap_custom_dkms_x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CasperVersion: 1.376
Date: Tue Sep 19 19:41:05 2017
InstallCmdLine: file=/cdrom/preseed/ubuntu-gnome.seed boot=casper initrd=/casper/initrd.lz quiet splash --- maybe-ubiquity
LiveMediaBuild: Ubuntu-GNOME 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160720)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

joseph (josephdonaire) wrote :

Exception during installation:
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: Traceback (most recent call last):
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1778, in <module>
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: install.run()
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 78, in wrapper
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: func(self)
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 204, in run
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: self.configure_plugins()
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 570, in configure_plugins
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: self.run_plugin(plugin)
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 547, in run_plugin
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: "Plugin %s failed with code %s" % (plugin.NAME, ret))
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py: ubiquity.install_misc.InstallStepError: Plugin usersetup failed with code 1
Sep 19 23:36:36 ubuntu-gnome /plugininstall.py:

tags: added: installer-crash
Phillip Susi (psusi) wrote :

And in your custom iso, did you install libpam-passwdqc or libpam-pwquality

Changed in ubiquity (Ubuntu):
status: New → Incomplete
joseph (josephdonaire) wrote :

Hello Phillip

it have libpam-passwdqc 1.3.0-1 amd64

Phillip Susi (psusi) wrote :

Well that would be why; you specifically configured the system not to accept weak passwords.

Changed in ubiquity (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers