ubi-console-setup fails with exit code 1

Bug #1715605 reported by Jean-Baptiste Lallement on 2017-09-07
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

artful desktop 20170907

When the user presses 'next' on the keyboard page, an error dialog is displayed with the following message:

"ubi-console-setup failed with exit code 1. ...." (full message in screenshot)

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: ubiquity 17.10.6
ProcVersionSignature: Ubuntu 4.12.0-12.13-generic 4.12.8
Uname: Linux 4.12.0-12-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CasperVersion: 1.384
CurrentDesktop: ubuntu:GNOME
Date: Thu Sep 7 12:18:52 2017
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --- keyboard-configuration/layoutcode=fr keyboard-configuration/variantcode=oss
LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170907)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Jeremy Soller (jackpot51) wrote :

Getting this issue too

Iain Lane (laney) wrote :

It should be fixed in the attached MP which cyphermox is going to upload soon

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 17.10.7

---------------
ubiquity (17.10.7) artful; urgency=medium

  [ Jean-Baptiste Lallement ]
  * Mark the files for oem-config as trusted so they are properly handled by
    nautilus. (LP: #1712581)

  [ Iain Lane ]
  * ubi-console-setup.py: Set DPKG_MAINTSCRIPT_{NAME,PACKAGE} variables for
    our manual running of keyboard-configuration.postinst. This script now
    runs dpkg-maintscript-helper to remove an old conffile. That code won't
    fire in ubiquity, but we still need to not error out. (LP: #1715605)

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 07 Sep 2017 11:02:30 -0400

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Tinh (tinhtrilac) wrote :

I got this error too when I tried to install Ubuntu 18.04 and Ubuntu 16.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers