Auto-selected keyboard layout no longer matches chosen region on "Where are you" page

Bug #1706859 reported by Rik Mills on 2017-07-27
76
This bug affects 13 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Kubuntu Or Ubuntu Mate 17.10 Alpha 2 iso image
Build 20170725

or

Ubuntu daily iso build

EDIT: This only seems to happen when you launch ubiquity in a live session. Starting the installation from the "try or install screen" instead seems to correctly set the matching keyboard layout by default.

EDIT2: 28/09/2017 - beta2 testing - This has now regressed so it seems to occur when installing from BOTH the Try/Install screen, and from the live session install links

Steps to reproduce:

- Start installation via either the Try/install screen. or the live session install links.
- On "Where are you page" set region and time zone to "United Kingdom" (London in Mate & Ubuntu's case)
- Go to next page "Keyboard Layout"

What happens:

I am offered by default the English (US) keyboard layout and variant.

What should happen:

In 17.04 and previous ubiquity versions, the appropriate English (UK) option was chosen/presented by default to match my location settings from the previous screen.

A regression like this could result in someone who is inattentive, or perhaps does many installs and simply assumes that the matching happens so does not notice, getting the wrong default keyboard setting on fresh install.

Rik Mills (rikmills) on 2017-07-27
tags: added: alpha2 artful
summary: - Auto-selected keyboard layout no longer matches chosen region on "Whare
+ Auto-selected keyboard layout no longer matches chosen region on "Where
are you" page
Rik Mills (rikmills) wrote :

This only seems to happen when you launch ubuiqity in a live session. Starting the installation from the "try or install screen" instead seems to correctly set the matching keyboard layout by default.

description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1706859

tags: added: iso-testing
Rik Mills (rikmills) wrote :

Also same behaviour in Ubuntu Mate

description: updated
Rik Mills (rikmills) wrote :

Also same for main ubuntu Alpha2 gnome iso

description: updated
description: updated
Rik Mills (rikmills) wrote :

I meant daily iso for Ubuntu

Rik Mills (rikmills) on 2017-07-27
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-17.10
Rik Mills (rikmills) on 2017-07-27
tags: added: kubuntu
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: rls-aa-incoming
fossfreedom (fossfreedom) wrote :

unlike #1 - on Ubuntu Budgie we see this issue occurring from the Try/Install screen as well EXCEPT (oddly) if encrypting/lvm the drive when the UK keyboard is then automatically chosen.

Will Cooke (willcooke) on 2017-09-27
tags: added: rls-bb-incoming
removed: rls-aa-incoming
Rik Mills (rikmills) wrote :

Doing iso testing this morning, I indeed see this on the Try/install screen as well.

So seems this issue has regressed further to effect both install paths.

description: updated
tags: added: beta2

I certainly can't reproduce this anymore. I've updated console-setup a few weeks ago to fix a clear issue in the config script that would affect this as well.

At this point, I consider this is fixed, closing the bug as Fix Released.

Please don't hesitate to re-open or file a new report if keymap selection doesn't work for you.

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
fossfreedom (fossfreedom) wrote :

Mathieu - still occurs in todays release candidate for Ubuntu Budgie.

Popey saw this when he was demonstrating as part of the 17.10 community iso testing ubuntu-on-air event.

i.e. english language - defaulted to London UK - next screen was US keyboard.

Rik Mills (rikmills) wrote :

The same on Kubuntu when I tested earlier with latest isos

Tested locations of London UK, and location/time zone of France with French language installer, and in both cases the installer preselected English (US) keyboard.

Rik Mills (rikmills) on 2017-10-17
Changed in ubiquity (Ubuntu):
status: Fix Released → Confirmed
Carla Sella (carla-sella) wrote :

When installing Ubuntu 17.10 http://cdimage.ubuntu.com/daily-live/20171018/artful-desktop-amd64.iso in Italian it proposed for English keyboard instead of Italian.

Ok; there's different behavior depending on whether someone picks language at the splash screen or at the welcome screen in the installer.

Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
milestone: ubuntu-17.10 → ubuntu-18.01
milestone: ubuntu-18.01 → ubuntu-17.11

The behaviour is also different if you start ubiquity from the live session or directly from 'Install Ubuntu'

nathan (nathan95-b) on 2017-11-12
Changed in ubiquity (Ubuntu):
status: Triaged → Confirmed
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
Maraschin (carlo-maraschin) wrote :

1. I installed 17.10 server today
2. I use English for language
3. and Swedish as the keyboard (select it with F3 before start the installation)
4. installation goes OK but it doesn't let me select the keyboard when installing, it seems to use the locale - which in this case will be US for the keyboard.
5. I tried to go back in the installation to select another keyboard but it will not allow me
6. After reboot I can't enter the encryption key since it has characters that doesn't exist in the US keyboard

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers