Ubuntu GNOME 17.04 Try or Install screen missing decorations

Bug #1675210 reported by Jeremy Bicha on 2017-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

I'm attaching screenshots comparing Ubuntu GNOME 16.10 with 17.04 on the Try on Install screen of the installer.

Ubuntu GNOME is missing the window decorations and the top panel (looks like gnome-shell).

This has been broken for a few weeks. I apologize for not reporting it sooner.

Things to check…
-----------------
1. gnome-settings-daemon has been split into separate binaries. This broke gnome-initial-setup's New User mode but was fixed with
https://git.gnome.org/browse/gnome-initial-setup/commit/?id=fd8ad0f
https://git.gnome.org/browse/gnome-initial-setup/commit/?id=d2c051c

2. Check if the code changes for Ubuntu Budgie could have broken Ubuntu GNOME.

3. Maybe we just need to update our data/ubiquity.json (installed to /usr/share/gnome-shell/modes/ ).

Update 1
--------
I can reproduce this bug with Ubuntu GNOME Alpha 1. That is before any of GNOME 3.24 landed so this should have nothing to do with the gnome-settings-daemon split. ubiquity was at 17.04.4

Compared to 16.10, gnome-shell, gnome-session, gdm3 and gtk had been updated from 3.20 to 3.22.

Related branches

Jeremy Bicha (jbicha) wrote :
description: updated
Jeremy Bicha (jbicha) on 2017-03-22
description: updated
Changed in ubuntu-gnome:
milestone: none → zesty
Jeremy Bicha (jbicha) on 2017-03-23
description: updated
Jeremy Bicha (jbicha) wrote :

Thanks fossfreedom for pointing out the fix.

Here's how I tested this fix:
Boot the iso into Install mode.
Click Quit.
Log out of GNOME.
Switch to a virtual terminal.
Log in as ubuntu-gnome.
sudo systemctl stop gdm
Make your changes (in this case, editing /usr/bin/ubiquity-dm)
sudo systemctl start ubiquity

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1675210

tags: added: iso-testing
Jeremy Bicha (jbicha) on 2017-04-03
Changed in ubuntu-gnome:
status: New → Fix Committed
Changed in ubiquity (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 17.04.9

---------------
ubiquity (17.04.9) zesty; urgency=medium

  * tests/test_misc.py: Really fix test for the 'ta' keymap: check for
    lk/tam_TAB in the list rather than asserting that it needs to be the first
    element; and allow for the different list size now.

 -- Mathieu Trudel-Lapierre <email address hidden> Sun, 09 Apr 2017 21:53:53 -0400

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2017-04-28
Changed in ubuntu-gnome:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers