Ubuntu Budgie - zesty Ubiquity crash when installing locales (daily 05Jan)

Bug #1654368 reported by fossfreedom on 2017-01-05
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
fossfreedom

Bug Description

Immediately after all the files have been copied, ubiquity reports that it has crashed

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: ubiquity 17.04.1
ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
Uname: Linux 4.9.0-11-generic x86_64
ApportVersion: 2.20.4-0ubuntu1
Architecture: amd64
CasperVersion: 1.380
Date: Thu Jan 5 19:30:05 2017
InstallCmdLine: boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash ---
JournalErrors:
 Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] failed with exit code 1: Hint: You are currently not seeing messages from other users and the system.
       Users in the 'systemd-journal' group can see all messages. Pass -q to
       turn off this notice.
 No journal files were opened due to insufficient permissions.
LiveMediaBuild: Ubuntu-Budgie 17.04 "Zesty Zapus" - Alpha amd64 (20170105.1)
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
 LC_NUMERIC=C.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

fossfreedom (fossfreedom) wrote :
fossfreedom (fossfreedom) wrote :

ok - looks to be a ubiquity permissions issue.

after a restart into the live cd ran sudo ubiquity gtk_ui and the installation completed successfully

Exception during installation:
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: Traceback (most recent call last):
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1710, in <module>
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: install.run()
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 60, in wrapper
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: func(self)
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 180, in run
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: self.configure_locale()
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 494, in configure_locale
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: self.run_plugin(language_plugin)
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 479, in run_plugin
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: "Plugin %s failed with code %s" % (plugin.NAME, ret))
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py: ubiquity.install_misc.InstallStepError: Plugin language failed with code 4
Jan 5 19:29:52 ubuntu-budgie /plugininstall.py:

tags: added: installer-crash

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
summary: - Ubiquity crash when installing locales
+ Ubuntu Budgie - zesty Ubiquity crash when installing locales (daily
+ 05Jan)
fossfreedom (fossfreedom) wrote :

debug file attached after trying ubiquity --debug

fossfreedom (fossfreedom) wrote :

linked proposed ubiquity branch for fix

Changed in ubiquity (Ubuntu):
assignee: nobody → fossfreedom (fossfreedom)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 17.04.2

---------------
ubiquity (17.04.2) zesty; urgency=medium

  [ David Mohammed ]
  * Update ubiquity-dm to support Ubuntu Budgie (LP: #1654368)

  [ Colin Watson ]
  * Automatic update of included source packages: partman-btrfs 26ubuntu1,
    partman-partitioning 114ubuntu1.

 -- Colin Watson <email address hidden> Sat, 07 Jan 2017 14:00:41 +0000

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers