kubuntu zesty 17.0.4.1 installation fails (2016-12-16 image)

Bug #1650767 reported by André Verwijs on 2016-12-17
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Mathieu Trudel-Lapierre

Bug Description

zesty 17.0.4.1 installation fails (2016-12-16 image) when i click "next" on installation
(after initial copy of core packages), installer crashes...

--

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 145, in process_line
    return self.dbfilter.process_line()
  File "/usr/lib/ubiquity/ubiquity/debconffilter.py", line 287, in process_line
    if not input_widgets[0].run(priority, question):
  File "/usr/lib/ubiquity/plugins/ubi-console-setup.py", line 502, in run
    self.ui.set_keyboard(misc.utf8(self.db.get(question)))
  File "/usr/lib/ubiquity/ubiquity/plugin.py", line 48, in wrapper
    return target(self, *args, **kwargs)
  File "/usr/lib/ubiquity/plugins/ubi-console-setup.py", line 350, in set_keyboard
    ly = keyboard_names.layout_id('C', misc.utf8(layout))
  File "/usr/lib/ubiquity/ubiquity/keyboard_names.py", line 142, in layout_id
    return kn.layout_id(lang, value)
  File "/usr/lib/ubiquity/ubiquity/keyboard_names.py", line 90, in layout_id
    return self._layout_by_human[value]
KeyError: 'English (US)'
QSocketNotifier: Invalid socket 20 and type 'Read', disabling...
QSocketNotifier: Invalid socket 20 and type 'Exception', disabling...
Exception in KDE frontend (invoking crash handler):
Traceback (most recent call last):
  File "/usr/lib/ubiquity/bin/ubiquity", line 655, in <module>
    main(oem_config)
  File "/usr/lib/ubiquity/bin/ubiquity", line 641, in main
    install(query=options.query)
  File "/usr/lib/ubiquity/bin/ubiquity", line 274, in install
    ret = wizard.run()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 512, in run
    if self.backup or self.dbfilter_handle_status():
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 857, in dbfilter_handle_status
    QtWidgets.QMessageBox.Close)
TypeError: warning(QWidget, str, str, buttons: Union[QMessageBox.StandardButtons, QMessageBox.StandardButton] = QMessageBox.Ok, defaultButton: QMessageBox.StandardButton = QMessageBox.NoButton): too many arguments

QSocketNotifier: Invalid socket 20 and type 'Write', disabling...

Related branches

André Verwijs (verwijs) wrote :
tags: added: zesty
André Verwijs (verwijs) wrote :
tags: added: kubuntu
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
André Verwijs (verwijs) wrote :

thank you..

Rik Mills (rikmills) wrote :

Confirmed on daily kubuntu iso 19/12/2016

Installer crashes when clicking continue on timezone settings page with the visible message:

Traceback (most recent call last):
  File "/usr/lib/ubiquity/bin/ubiquity", line 655, in <module>
    main(oem_config)
  File "/usr/lib/ubiquity/bin/ubiquity", line 639, in main
    install(args[0], query=options.query)
  File "/usr/lib/ubiquity/bin/ubiquity", line 274, in install
    ret = wizard.run()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 512, in run
    if self.backup or self.dbfilter_handle_status():
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 857, in dbfilter_handle_status
    QtWidgets.QMessageBox.Close)
TypeError: warning(QWidget, str, str, buttons: Union[QMessageBox.StandardButtons, QMessageBox.StandardButton] = QMessageBox.Ok, defaultButton: QMessageBox.StandardButton = QMessageBox.NoButton): too many arguments

Rik Mills (rikmills) wrote :

Force downgrading ubiquity and it's KDE frontend from 17.0.4.1 to 16.10.14 produces an error free install of today's 17. daily image.

So seems that the issue, at least in part, lies in the new 17.04.1 ubiquity version uploaded on 2016-12-13

Rik Mills (rikmills) on 2016-12-22
summary: - zesty 17.0.4.1 installation fails (2016-12-16 image)
+ kubuntu zesty 17.0.4.1 installation fails (2016-12-16 image)
Rik Mills (rikmills) wrote :

Still failing to install with same error on today's image

20161222

Walter Lapchynski (wxl) wrote :

There was some discussion about this:
https://irclogs.ubuntu.com/2016/12/19/%23ubuntu-installer.html#t15:58
https://irclogs.ubuntu.com/2016/12/20/%23ubuntu-installer.html#t03:06
with the take home message being that cyphermox is planning on a fix.

This is still ongoing with 20161222, so it's still in need of it. Suffice it to say, this will certainly affect any chance of Kubuntu doing alphas.

Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Critical
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
milestone: none → ubuntu-16.12
Rik Mills (rikmills) wrote :

On daily iso 20161228 installer still crashss as per the original report

Screenshot attatched

Patryk Jankun (inoperable) wrote :

This crash seems to be generated by partman, at least in my case, after commenting out a button argument in "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", around line 857 in the function call I get 2 buttons and tihs message instead ;)

ubi-partman failed with exit code 10. Further information may be found in /var/log/syslog. Do you want to try running this step again before continuing? If you do not, your installation may fail entirely or may be broken.

Patryk Jankun (inoperable) wrote :

after looking into this a bit deeper, partman log look like this:

/bin/partman: *******************************************************
/bin/partman: *******************************************************
/bin/partman: *******************************************************
/bin/partman: *******************************************************

this line shows up after each frequent crash/restart just before the the python script calls and crashes with buttons too many args message. Not very informative output o.O

Patryk Jankun (inoperable) wrote :

OK, I got rid of the partman bug by rechecking GPT partitions for errors, here is what I found:

If you start the installation from a live USB image - I dd'ed mine, but the USB writer does the same and produces a bad GPT table - and this seems to crash partman after manual partition selection.

second bug I encountered is within keyboard setup, as seen below:

Exception caught in process_line:
Traceback (most recent call last):
  File "/usr/lib/ubiquity/plugins/ubi-console-setup.py", line 348, in set_keyboard
    ly = keyboard_names.layout_id(lang, misc.utf8(layout))
  File "/usr/lib/ubiquity/ubiquity/keyboard_names.py", line 142, in layout_id
    return kn.layout_id(lang, value)
  File "/usr/lib/ubiquity/ubiquity/keyboard_names.py", line 90, in layout_id
    return self._layout_by_human[value]
KeyError: 'Polish'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 145, in process_line
    return self.dbfilter.process_line()
  File "/usr/lib/ubiquity/ubiquity/debconffilter.py", line 287, in process_line
    if not input_widgets[0].run(priority, question):
  File "/usr/lib/ubiquity/plugins/ubi-console-setup.py", line 502, in run
    self.ui.set_keyboard(misc.utf8(self.db.get(question)))
  File "/usr/lib/ubiquity/ubiquity/plugin.py", line 48, in wrapper
    return target(self, *args, **kwargs)
  File "/usr/lib/ubiquity/plugins/ubi-console-setup.py", line 350, in set_keyboard
    ly = keyboard_names.layout_id('C', misc.utf8(layout))
  File "/usr/lib/ubiquity/ubiquity/keyboard_names.py", line 142, in layout_id
    return kn.layout_id(lang, value)
  File "/usr/lib/ubiquity/ubiquity/keyboard_names.py", line 90, in layout_id
    return self._layout_by_human[value]
KeyError: 'Polish'

Setting "Polish" was automatically selected based on my IP location (I guess, since it was auto-selected), and this keyboard/location auto-setting is another problem.

I'm not a dev and my python is ~rusty at least, but I share my findings here. Let me know if that's helpful or not.

Changed in ubiquity (Ubuntu):
milestone: ubuntu-16.12 → ubuntu-17.01
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 17.04.3

---------------
ubiquity (17.04.3) zesty; urgency=medium

  * Automatic update of included source packages: netcfg 1.138ubuntu3.
  * kde_ui.py: Fix QMessageBox warning call to use "StandardButtons" ORed list
    of Retry/Ignore/Cancel buttons rather than each as new arguments, as the
    latter form is obsolete and breaks the Kubuntu installer. (LP: #1650767)
  * debian/rules: add ./ to the path for KeyboardNames.pl when we go to build
    kbdnames.gz; otherwise it looks as though kbdnames-maker won't find our
    list of keyboard models, layouts and variants. (LP: #1650767)

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 09 Jan 2017 16:38:01 -0500

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
dave nelson (davidnelson) wrote :

works fine now, thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers