install to external hdd fails

Bug #164481 reported by rax_m on 2007-11-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Hi

I tried to install Gutsy to an external USB hdd from the both the 32-bit and 64-bit live cd's. The installer starts fine, but after the partitioning step the installer get stuck at 15% (Scanning filesystems) both times.

The CPU usage seems quite high at about 40% with a process called 01unmount_busy (i think) using the CPU, but after 30 mins still no progress.

Let me know if you need more info.

Cheers
Rax

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in ubiquity.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. If possible could you please add the log reports as indicated at https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs ? Thanks in advance.

Changed in ubiquity:
status: New → Incomplete
godrik (godrik) wrote :

Hello,
i had the same problem using ubuntu 7.10. The installer stops at 15% an "detecting filesystems".
The log does not indicate anything interesting. However, i found an easy workaround.
In a terminal, check the device(s) associated with your external drive using df or mount. (at home, it was sdb1).
Then, unmount it using sudo umount /dev/sdb1
The installer is still blocked.
get the pid of 01unmount_busy. It should be the first in top then kill it.
the installer will re-ask you about the partionning.
This time, it will work.

Thanks for the info Godrik.. I will give this a try sometime.

To the dev.. sorry I haven't had a chance to test this yet. My new year has been hectic so far. Hopefull I'll be able to test this in about 2 weeks time.

Cheers
Rax

godrik <email address hidden> wrote: Hello,
i had the same problem using ubuntu 7.10. The installer stops at 15% an "detecting filesystems".
The log does not indicate anything interesting. However, i found an easy workaround.
In a terminal, check the device(s) associated with your external drive using df or mount. (at home, it was sdb1).
Then, unmount it using sudo umount /dev/sdb1
The installer is still blocked.
get the pid of 01unmount_busy. It should be the first in top then kill it.
the installer will re-ask you about the partionning.
This time, it will work.

--
install to external hdd fails
https://bugs.launchpad.net/bugs/164481
You received this bug notification because you are a direct subscriber
of the bug.

---------------------------------
 Sent from Yahoo! &#45; a smarter inbox.

Brian Murray (brian-murray) wrote :

It would still be useful if you were to submit the log files as that is what the developers want. Additionally, if someone could test this with Hardy Heron Alpha 2 that would be fantastic. You can learn more about Hardy at http://www.ubuntu.com/testing/ and find a link to download it.

rax_m (rax-m) wrote :

Hi,

Sorry for the delay in getting these logs files to you. Hope these help.

Cheers
Rax

Changed in ubiquity:
importance: Undecided → Medium
status: Incomplete → Confirmed
macUbuntu (brooks-stephenson) wrote :

nice work. I used your technique and it worked flawlessly

godrik wrote on 2008-01-04: (permalink)

Hello,
i had the same problem using ubuntu 7.10. The installer stops at 15% an "detecting filesystems".
The log does not indicate anything interesting. However, i found an easy workaround.
In a terminal, check the device(s) associated with your external drive using df or mount. (at home, it was sdb1).
Then, unmount it using sudo umount /dev/sdb1
The installer is still blocked.
get the pid of 01unmount_busy. It should be the first in top then kill it.
the installer will re-ask you about the partionning.
This time, it will work.

Is this still an issue for you? Which Ubuntu version do you use? Thank you for telling us!

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
rax_m (rax-m) wrote :

Hi

Nope I'm now on 12.04 which doesn't have the issue.

Regards rakesh

On 22 Nov 2012, at 14:55, Thomas Hotz <email address hidden> wrote:

> Is this still an issue for you? Which Ubuntu version do you use? Thank
> you for telling us!
>
> ** Changed in: ubiquity (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/164481
>
> Title:
> install to external hdd fails
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/164481/+subscriptions

Changed in ubiquity (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments