double header in 16.10

Bug #1622686 reported by Dave Morley on 2016-09-12
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
humanity-icon-theme (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
Yakkety
Medium
Unassigned
ubiquity (Ubuntu)
Medium
Mathieu Trudel-Lapierre
Xenial
Low
Mathieu Trudel-Lapierre
Yakkety
Low
Unassigned

Bug Description

[Impact]

During install and oem-firstboot, the header bar at the top of the screen in Ubiquity is twice as tall as it should be on hidpi screens (looking like two normal sized header bars stacked on top of each other), and the blue a11y icon is double sized.

This looks obviously incorrect and ugly and makes a bad first impression on users installing Ubuntu on a hidpi laptop or customers of Ubuntu OEMs booting new machines for the first time. Arstechnica commented negatively on this in their review of Dell's XPS 13: http://arstechnica.com/gadgets/2017/01/dells-latest-xps-13-de-still-delivers-linux-now-embraces-svelte-hardware/

Users of the Dell XPS 13 are affected as well as users of other brands of laptops with hidpi screens. System76 is temporarily carrying a patched version of Humanity to work around this bug.

The a11y icon is double-sized because the version of Humanity shipping in Ubuntu doesn't support @2 hidpi scaling, which results in the header bar doubling its height. Because the header bar is drawn with CAIRO_PAD_REPEAT, the gradient is repeated so it looks like two bars stacked one on top of the other. The fix to the Humanity icon theme adds @2 hidpi support, which shrinks the icon and restores the header bar to its normal height.

[Test Case]
ISO install:
1. Grab an Ubuntu iso and proceed to install (not "try") Ubuntu on a computer with a hidpi screen.
2. Note the double-sized header and icon during install.
    - Using an iso with a fixed version of Humanity, the header and icon should look normal.

OEM-Firstboot:
1. Grab an Ubuntu iso and do an oem-install on on a computer with a hidpi screen.
2. After installing, click the launcher icon to "Prepare for shipping to the end user" and reboot.
3. During oem-firstboot, note the double-sized header and icon during install.
    - To test the fix, install a fixed version of humanity before preparing the system for the end user.

[Regression Potential]

This patch affects the look of anything using the Humanity icon set. The look of Nautilus, and many other GTK apps will be affected. This is not a regression but fixes another bug and resolves a discrepancy between rendering of icons on hidpi screens vs lowdpi screens.

The biggest risk for regression comes from the off chance that there is an error or omission in the index.theme files. Comparing icons on a broad range of applications and systems should catch this class of issues. If any issues with icons are found, check there.

Related branches

Dave Morley (davmor2) wrote :
Sebastien Bacher (seb128) wrote :

I can't confirm in virtualbox here on a lowdpi screen, might be hidpi specific?

tags: added: rls-y-incoming
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
tags: added: iso-testing
Dave Morley (davmor2) on 2016-09-23
description: updated
Martin Wimpress (flexiondotorg) wrote :

I can confirm on Dell XPS 15 with UHD screen.

Ads20000 (ads20000) on 2016-09-26
Changed in ubiquity (Ubuntu):
status: New → Confirmed
System76 (salmon76) wrote :

I can confirm on multiple hidpi machines that this bug is present during oem firstboot. This bug was noted in particular in Ars Technica's review of the XPS 13: http://arstechnica.com/gadgets/2017/01/dells-latest-xps-13-de-still-delivers-linux-now-embraces-svelte-hardware/

This would be really nice to get fixed, both for oems and for users with hidpi laptops.

Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
Changed in ubiquity (Ubuntu):
status: Triaged → In Progress
Changed in ubiquity (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
milestone: none → ubuntu-17.01
David Jordan (dmj726) wrote :

I tested Mathieu's patch (relavant portion attached here), and it definitely provides an improvement, but doesn't fully fix the bug. Instead of repeating, the bottom half of the panel is dark and flat.

David Jordan (dmj726) wrote :

Her is what the above changes do on a hidpi screen.

David Jordan (dmj726) wrote :

So, I've been working on adding hidpi support in the Humanity icon theme today, and noticed that the blue accessibility icon looks like one of the icons in Humanity.

After installing my updated Humanity icon (with @2x support added) the blue accessibility icon is the correct size, and the panel is no longer double height. The icon was simply too big and the panel was resizing to match, so updating humanity to support @2x icons should fix the incorrect panel height.

However, Matheiu's code does improve the appearance of the bottom pixels of the panel. Previously, there was a small band at the bottom of the panel that repeated the much lighter shade of the top of the panel. With the patch, that band uses the darker color immediately above. You can see the difference in the attached image (with the @2x humanity theme in both cases).

The attachment "cairo_extend_pad-snippet.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Matt Coleman (mcoleman) wrote :

I also tested Mathieu's patch and observed the same results. Photos here: http://imgur.com/a/16H89

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 17.04.4

---------------
ubiquity (17.04.4) zesty; urgency=medium

  [ Mathieu Trudel-Lapierre ]
  * Set extend property for the panel to CAIRO_EXTEND_PAD rather than REPEAT,
    so HiDPI will look slightly better with a nicer edge to the bottom of the
    panel, in the right color, rather than possibly repeating the gradient.
    (LP: #1622686)
  * Automatic update of included source packages: grub-installer
    1.128ubuntu7, netcfg 1.138ubuntu4, partman-btrfs 29ubuntu1, partman-
    partitioning 114ubuntu2.

  [ Max Brustkern ]
  * Set gail or autopilot to GTK_MODULES if GTK_MODULES is empty, rather
    than always trying to append. (LP: #1654630)

  [ David Mohammed ]
  * Update ubiquity-dm to ensure Ubuntu Budgie displays its panel
    to allow users to use the network-manager applet (LP: #1657447)

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 23 Jan 2017 13:02:20 -0500

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
Iain Lane (laney) on 2017-01-24
Changed in humanity-icon-theme (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.6.12

---------------
humanity-icon-theme (0.6.12) zesty; urgency=medium

  * Add hidpi @2 support (LP: #1657863, #1622686)

 -- David Jordan <email address hidden> Mon, 23 Jan 2017 12:29:57 -0700

Changed in humanity-icon-theme (Ubuntu):
status: Fix Committed → Fix Released
David Jordan (dmj726) on 2017-01-24
description: updated

Hello Dave, or anyone else affected,

Accepted humanity-icon-theme into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/humanity-icon-theme/0.6.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in humanity-icon-theme (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Changed in humanity-icon-theme (Ubuntu Yakkety):
status: New → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Dave, or anyone else affected,

Accepted humanity-icon-theme into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/humanity-icon-theme/0.6.11.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in humanity-icon-theme (Ubuntu Xenial):
importance: Undecided → Low
Changed in ubiquity (Ubuntu Xenial):
importance: Undecided → Medium
Changed in ubiquity (Ubuntu Yakkety):
importance: Undecided → Medium
Changed in humanity-icon-theme (Ubuntu):
importance: Undecided → Low
importance: Low → Medium
Changed in humanity-icon-theme (Ubuntu Xenial):
importance: Low → Medium
Changed in humanity-icon-theme (Ubuntu Yakkety):
importance: Undecided → Medium
Changed in ubiquity (Ubuntu Xenial):
importance: Medium → Low
Changed in ubiquity (Ubuntu Yakkety):
importance: Medium → Low
tags: removed: 16.10 rls-y-incoming
David Jordan (dmj726) wrote :

Did some quick testing with the 0.6.11.1 package in -proposed, and can verify that it fixes this bug.

tags: added: verification-done
removed: verification-needed
David Jordan (dmj726) wrote :

Did some quick testing with the 0.6.10.1 package in -proposed, and can verify that it fixes this bug.

I installed Xenial daily, completed an oem-setup, installed humanity-icon-theme 0.6.10.1 and prepared the system. I confirm that the double header in oem-firstboot is fixed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.6.10.1

---------------
humanity-icon-theme (0.6.10.1) xenial; urgency=medium

  [ David Jordan ]
  * Add hidpi @2 support (LP: #1657863, #1622686)

  [ Iain Lane ]
  * Set Vcs-Bzr for xenial.

 -- David Jordan <email address hidden> Wed, 25 Jan 2017 10:58:57 +0000

Changed in humanity-icon-theme (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for humanity-icon-theme has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.6.11.1

---------------
humanity-icon-theme (0.6.11.1) yakkety; urgency=medium

  [ David Jordan ]
  * Add hidpi @2 support (LP: #1657863, #1622686)

  [ Iain Lane ]
  * Update Vcs-Bzr for yakkety

 -- David Jordan <email address hidden> Wed, 25 Jan 2017 11:29:32 +0000

Changed in humanity-icon-theme (Ubuntu Yakkety):
status: Fix Committed → Fix Released

Since it's reportedly fixed just by modifying the icon theme in SRUs, let's not introduce changes to ubiquity now.

For yakkety; this is Won't Fix: we're not doing point-releases, so even if it was available, it would not benefit many installs (given that ubiquity would need to be on the ISO for the changes to apply to direct installs (rather than live)).

For xenial, I'm applying the changes to the bzr branch for the next ubiquity upload.

Changed in ubiquity (Ubuntu Yakkety):
status: New → Won't Fix
Changed in ubiquity (Ubuntu Xenial):
status: New → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Changed in ubiquity (Ubuntu Xenial):
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers