Ubiquity Installer Crashes KDE Daily Build 16.10

Bug #1595045 reported by Gene Soo on 2016-06-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Traceback (most recent call last):
  File "/usr/lib/ubiquity/bin/ubiquity", line 649, in <module>
    main(oem_config)
  File "/usr/lib/ubiquity/bin/ubiquity", line 633, in main
    install(args[0], query=options.query)
  File "/usr/lib/ubiquity/bin/ubiquity", line 268, in install
    ret = wizard.run()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 525, in run
    self.start_slideshow()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 641, in start_slideshow
    webView = self._create_webview()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 594, in _create_webview
    from PyQt4.QtWebKit import QWebView
ImportError: No module named 'PyQt4.QtWebKit'

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: ubiquity 16.10.2
ProcVersionSignature: Ubuntu 4.4.0-25.44-generic 4.4.13
Uname: Linux 4.4.0-25-generic x86_64
ApportVersion: 2.20.2-0ubuntu1
Architecture: amd64
CasperVersion: 1.376
Date: Wed Jun 22 00:45:00 2016
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InstallCmdLine: file=/cdrom/preseed/kubuntu.seed boot=casper maybe-ubiquity initrd=/casper/initrd.lz quiet splash --- maybe-ubiquity
InterpreterPath: /usr/bin/python3.5
LiveMediaBuild: Kubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160621)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Gene Soo (genesoo77072) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Phillip Susi (psusi) wrote :

Is this still happening with current daylies?

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Philip Muškovac (yofel) wrote :

"No" - as I removed the kubuntu slideshow from the seed, so nothing tries to be rendered, and nothing crashes. Hardly a solution to the problem as now a user looks at an empty window while the installation is running. I'm not sure if we have a separate bug about qyqt4.QtWebkit missing (after talking to debian I agree that that's a good idea) or porting our ubiquity frontent to Qt5.

Sorry for the delay in replying. As far as I can tell, the problem is Not
happening in the Dailies any more.

On Thu, Jul 14, 2016 at 9:51 AM, Phillip Susi <email address hidden> wrote:

> Is this still happening with current daylies?
>
>
> ** Changed in: ubiquity (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1595045
>
> Title:
> Ubiquity Installer Crashes KDE Daily Build 16.10
>
> Status in ubiquity package in Ubuntu:
> Incomplete
>
> Bug description:
> Traceback (most recent call last):
> File "/usr/lib/ubiquity/bin/ubiquity", line 649, in <module>
> main(oem_config)
> File "/usr/lib/ubiquity/bin/ubiquity", line 633, in main
> install(args[0], query=options.query)
> File "/usr/lib/ubiquity/bin/ubiquity", line 268, in install
> ret = wizard.run()
> File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 525, in run
> self.start_slideshow()
> File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 641, in
> start_slideshow
> webView = self._create_webview()
> File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 594, in
> _create_webview
> from PyQt4.QtWebKit import QWebView
> ImportError: No module named 'PyQt4.QtWebKit'
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.10
> Package: ubiquity 16.10.2
> ProcVersionSignature: Ubuntu 4.4.0-25.44-generic 4.4.13
> Uname: Linux 4.4.0-25-generic x86_64
> ApportVersion: 2.20.2-0ubuntu1
> Architecture: amd64
> CasperVersion: 1.376
> Date: Wed Jun 22 00:45:00 2016
> ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
> InstallCmdLine: file=/cdrom/preseed/kubuntu.seed boot=casper
> maybe-ubiquity initrd=/casper/initrd.lz quiet splash --- maybe-ubiquity
> InterpreterPath: /usr/bin/python3.5
> LiveMediaBuild: Kubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160621)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: ubiquity
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1595045/+subscriptions
>

Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers