The creation of a BTRFS or XFS partition fails during install of Lubuntu Daily Live image

Bug #1591851 reported by Brendan Perrine on 2016-06-13
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
lubuntu-meta (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Problem: You cannot create a BTRFS or XFS partition on the Lubuntu daily desktop image using ubiquity.

Expected: You should be able to create a BTRFS or XFS partition during the install of the Lubuntu daily desktop image.

How to reproduce:
 1. Download, install, and boot a daily Lubuntu desktop image.
 2. At the partitioning step, select manual partitioning
 3. Create a BTRFS or XFS partition
 4. Attempt to continue with the installation and the partition creation fails

Workaround: Install the `btrfs-progs` and `xfsprogs` packages to enable support.

Brendan Perrine (walterorlin) wrote :
Brendan Perrine (walterorlin) wrote :

This might be because btrfs-progs is not seeded for lubuntu on the install image I get this in the installer.

btrfs-progs:
  Installed: (none)
  Candidate: 4.5.2-1
  Version table:
     4.5.2-1 500
        500 http://archive.ubuntu.com/ubuntu yakkety/main amd64 Packages

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
sudodus (nio-wiklund) wrote :

I can confirm the bug. I can also confirm, that it works to install into a root partition with a btrfs file system after installing btrfs-progs into the live system. Good catch :-)

I tested with the Lubuntu Yakkety 64-bit current daily iso file.

krdondon (candan) wrote :

tendency bug
ubiquity install(setup)
or gnome(compatibility)

.. ;)

But off.
He said developer General bug.
T^T..
The installation should proceed.

krdondon (candan) wrote :

Add your comments ...
Thank update patch.
Fixed errors.
But..

Additional occur.
root usb ..
usb fat32 format.
After that..
General users .. not ..
Usb and is recognized as a root form.
If you try to copy a file.
root should be copied.
You do not have permission.

This was so elevated privileges.
usb must be the user's authority.

summary: - creation of btrfs partition fails during install
+ creation of btrfs or xfs partition fails during install
Simon Quigley (tsimonq2) on 2016-06-30
description: updated
summary: - creation of btrfs or xfs partition fails during install
+ The creation of a BTRFS or XFS partition fails during install of Lubuntu
+ Daily Live image
Changed in lubuntu-meta (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
assignee: Simon Quigley (tsimonq2) → nobody
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1591851

tags: added: iso-testing
Martin Wimpress (flexiondotorg) wrote :

Unable to reproduce on Ubuntu MATE 16.10 Alpha 2.

Brendan Perrine (walterorlin) wrote :

I do not get this anymore on the lubuntu 16.10 alpha 2 and now has xfsprogs in the manifest so this seems to have been fixed indepenedntly of this bug report.

Changed in lubuntu-meta (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers