installer formats disk although "Back" was clicked to return to previous screen

Bug #1586825 reported by Jens on 2016-05-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

I am running Ubuntu 14.04 on a computer with three harddisks. I need to install 16.04 on a specific disk so I disconnected two of the three disks and booted the 16.04 install via USB (EFI).

The disk in question at that time hosted an encrypted LVM volume with data only which I was able to mount in the 16.04 live system using Nautilus (but not access, possibly due to mismatching user IDs).

I started the installer on the desktop and selected to install updates and encrypt the system.
I clicked through UNTIL the point where an additional popup window told me that it would now format the disks with the following layout (...) if I proceed.

At that point I backed out and clicked "Back" several times, going back several steps until the point where I could choose whether to use LVM and encryption. Then I closed the installer.

At that point, my target disk - which held a data partition before - was already formatted although I had backed out of the installer:

  Medium /dev/sda: 465.8 GiB, 500107862016 Bytes, 976773168 Sektoren

  Gerät Start Ende Sektoren Größe Typ
  /dev/sda1 2048 1050623 1048576 512M EFI System
  /dev/sda2 1050624 2050047 999424 488M Linux filesystem
  /dev/sda3 2050048 976771071 974721024 464.8G Linux filesystem

I am *100% sure* I did *not* click on "Proceed" at the prompt where the partitioning layout was shown.
Please try to reproduce this, if it is reproducible it is a serious bug.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.63
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.376
CurrentDesktop: Unity
Date: Sun May 29 19:33:32 2016
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---
LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jens (jens-launchpad-net) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Reviewing your log files attached to this bug report it seems that there is a problem with your installation media (CD/DVD). You can verify the integrity of the Ubuntu ISO files you downloaded by following the instructions at https://help.ubuntu.com/community/HowToMD5SUM. You might also retry your installation with new media. In the event that is is not in fact an error with your installation media please set the bug's status back to New. Thanks and good luck!

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

Changed in ubiquity (Ubuntu):
status: New → Incomplete
tags: added: ident-mismatch
Jens (jens-launchpad-net) wrote :

No errors according to MD5sum check on installation media.

Changed in ubiquity (Ubuntu):
status: Incomplete → New
summary: - installer formats disk although I backed out!
+ installer formats disk although "Back" was clicked to return to previous
+ screen
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers