Location/Timezone picker crashes on install

Bug #1584417 reported by Yuri Astrakhan on 2016-05-22
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Unassigned
ubiquity (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

During Ubuntu 16.04LTS install, in the "Where are you?" screen, ubiquity crashes with AttributeError in geoname_add_tzdb(): NoneType object has no attribute 'human_country'.

Retyping by hand since this afterwards it crashes the install

Traceback:
File /usr/lib/ubiquity/plugins/ubi-timezone.py line 165 in geoname_cb
  self.geoname_add_tzdb(text,model)
File /usr/lib/ubiquity/plugins/ubi-timezone.py line 145 in geoname_add_tzdb
  model.append([name, '', loc.human_country,
AttributeError: NoneType object has no attribute 'human_country'

ApportVersion 2.20.1-0ubuntu2
Ubiquity 2.21.63

Repo steps:
* in the text box, erase the value, and start typing "st". It crashes after the letter "s" (freezes, with the crash windows hidden behind the main one)

Related branches

Yuri Astrakhan (yuriastrakhan) wrote :

P.S. I might have typed semicolon after "s". Will try to attach logs shortly.

Yuri Astrakhan (yuriastrakhan) wrote :

Syslog:

May 22 05:31:31 ubuntu ubiquity[1739]: Geoname lookup for ";" failed: 2 Error resolving 'geoname-lookup.ubuntu.com': Temporary failure in name resolution
May 22 05:31:34 ubuntu ubiquity[1739]: Exception in GTK frontend (invoking crash handler):
May 22 05:31:34 ubuntu ubiquity[1739]: Traceback (most recent call last):
May 22 05:31:34 ubuntu ubiquity[1739]: File "/usr/lib/ubiquity/plugins/ubi-timezone.py", line 165, in geoname_cb
May 22 05:31:34 ubuntu ubiquity[1739]: self.geoname_add_tzdb(text, model)
May 22 05:31:34 ubuntu ubiquity[1739]: File "/usr/lib/ubiquity/plugins/ubi-timezone.py", line 145, in geoname_add_tzdb
May 22 05:31:34 ubuntu ubiquity[1739]: model.append([name, '', loc.human_country,
May 22 05:31:34 ubuntu ubiquity[1739]: AttributeError: 'NoneType' object has no attribute 'human_country'
May 22 05:31:34 ubuntu ubiquity[1739]:
May 22 05:31:34 ubuntu ubiquity: Gtk-Message: Failed to load module "overlay-scrollbar"
May 22 05:31:34 ubuntu ubiquity: Gtk-Message: Failed to load module "overlay-scrollbar"

debug:

/usr/lib/ubiquity/plugins/ubi-timezone.py:98: PyGIWarning: Soup was imported without specifying a version first. Use gi.require_version('Soup', '2.4') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GObject, GLib, Soup
/usr/lib/ubiquity/plugins/ubi-timezone.py:208: Warning: Source ID 5745 was not found when attempting to remove it
  GLib.source_remove(self.timeout_id)
/usr/lib/ubiquity/plugins/ubi-timezone.py:208: Warning: Source ID 5982 was not found when attempting to remove it
  GLib.source_remove(self.timeout_id)
/usr/lib/ubiquity/plugins/ubi-timezone.py:208: Warning: Source ID 6011 was not found when attempting to remove it
  GLib.source_remove(self.timeout_id)
Could not understand timezone Mexico/Cancun
Could not understand timezone Mexico/Hermosillo
Exception in GTK frontend (invoking crash handler):
Traceback (most recent call last):
  File "/usr/lib/ubiquity/plugins/ubi-timezone.py", line 165, in geoname_cb
    self.geoname_add_tzdb(text, model)
  File "/usr/lib/ubiquity/plugins/ubi-timezone.py", line 145, in geoname_add_tzdb
    model.append([name, '', loc.human_country,
AttributeError: 'NoneType' object has no attribute 'human_country'

Traceback (most recent call last):
  File "/usr/lib/ubiquity/plugins/ubi-timezone.py", line 165, in geoname_cb
    self.geoname_add_tzdb(text, model)
  File "/usr/lib/ubiquity/plugins/ubi-timezone.py", line 145, in geoname_add_tzdb
    model.append([name, '', loc.human_country,
AttributeError: 'NoneType' object has no attribute 'human_country'
/usr/lib/ubiquity/plugins/ubi-timezone.py:208: Warning: Source ID 6022 was not found when attempting to remove it
  GLib.source_remove(self.timeout_id)
No such schema 'org.mate.SettingsDaemon.plugins.media-keys'

(a11y-profile-manager-indicator:2008): Gdk-WARNING **: a11y-profile-manager-indicator: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Kent Lin (kent-jclin) on 2016-06-24
Changed in oem-priority:
importance: Undecided → Critical
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Changed in ubiquity (Ubuntu Xenial):
status: New → In Progress
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Changed in ubiquity (Ubuntu Xenial):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 16.10.4

---------------
ubiquity (16.10.4) yakkety; urgency=high

  [ Shih-Yuan Lee (FourDollars) ]
  * Some places doesn't have the location information. (LP: #1584417)

  [ Dimitri John Ledkov ]
  * Fix substitution variables syntax from $() -> ${} in
    translations. (LP: #1603926)
  * Automatic update of included source packages: clock-setup
    0.128ubuntu1, partman-base 187ubuntu3, partman-btrfs 21ubuntu1.

 -- Dimitri John Ledkov <email address hidden> Mon, 18 Jul 2016 12:12:43 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released

Hello Yuri, or anyone else affected,

Accepted ubiquity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubiquity/2.21.63.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Ara Pulido (ara) on 2016-07-18
Changed in oem-priority:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.63.2

---------------
ubiquity (2.21.63.2) xenial; urgency=high

  [ Shih-Yuan Lee (FourDollars) ]
  * Some places doesn't have the location information. (LP: #1584417)

  [ Dimitri John Ledkov ]
  * Fix substitution variables syntax from $() -> ${} in
    translations. (LP: #1603926)
  * Automatic update of included source packages: console-setup
    1.108ubuntu15.2, partman-base 187ubuntu2.1.

 -- Dimitri John Ledkov <email address hidden> Mon, 18 Jul 2016 14:28:29 +0100

Changed in ubiquity (Ubuntu Xenial):
status: Fix Committed → Fix Released
Dimitri John Ledkov (xnox) wrote :

verified that various input locations that used to trigger this bug, no longer freeze ubiquity.

tags: added: verification-done
removed: verification-needed
Ara Pulido (ara) on 2016-07-26
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers