xenial: Kubuntu Daily Image Ubiquity cannot connect to X server :0

Bug #1571899 reported by Scarlett Gately Moore on 2016-04-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Ubuntu Installer Team

Bug Description

kubuntu@kubuntu:~$ cat /var/log/Xorg.0.log | grep EE
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 16.581] (EE) Failed to load module "nvidia" (module does not exist, 0)
[ 16.604] (EE) Failed to load module "nvidia" (module does not exist, 0)
[ 16.618] (EE) Unknown chipset: NV117
[ 20.893] (EE)
[ 20.893] (EE) xf86OpenConsole: Switching VT failed
[ 20.893] (EE)
[ 20.893] (EE)
[ 20.893] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 20.893] (EE)
[ 20.893] (EE) Server terminated with error (1). Closing log file.
kubuntu@kubuntu:~$ cat /var/log/installer/debug
Ubiquity 2.21.57
: cannot connect to X server :0
Ubiquity 2.21.57
TEXT <small>If more than one person will use this computer, you can set up multiple accounts after installation.</small>
TEXT <small>Enter the same password twice, so that it can be checked for typing errors.</small>
TEXT <small>The name it uses when it talks to other computers.</small>
kubuntu@kubuntu:~$

Scarlett Gately Moore (sgclark) wrote :
  • dm Edit (2.0 KiB, text/plain)
Changed in ubuntu:
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1571899/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Scarlett Gately Moore (sgclark) wrote :

I do not know who/what handles graphic drivers on the install medium

THe exact same install medium installs fine on machine with intel graphic card. So something with nvidia.

affects: ubuntu → ubiquity
Changed in ubiquity:
milestone: ubuntu-16.04 → none
Colin Watson (cjwatson) on 2016-04-19
affects: ubiquity → ubiquity (Ubuntu)
tags: added: xenial
Brian Murray (brian-murray) wrote :

If the whole live CD fails to have a usable X session then that sounds like a bug in the X stack, not something with ubiquity.

Scarlett Gately Moore (sgclark) wrote :

Yes I admitted above to not having a clue where to assign this bug. It is only on install as this laptop has a functional xenial running (was testing last daily ) and startx works fine after switching alt + f2 so I am not convinced x stack is at fault.

Scarlett

What is result of:

loginctl show-session $XDG_SESSION_ID

Same issue in bug #1559576 (Ubuntu GNOME boots to black screen when using proprietary Nvidia drivers on a laptop with Optimus)

Which is listed on GNOME release notes 16.04 (known Issues)

summary: - Kubuntu Daily Image Ubiquity cannot connect to X server :0
+ xenial: Kubuntu Daily Image Ubiquity cannot connect to X server :0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments