Nvidia driver not installed

Bug #1571781 reported by Mike Bibbings on 2016-04-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythbuntu-meta (Ubuntu)
High
Unassigned
ubiquity (Ubuntu)
High
Unassigned

Bug Description

mythtv testing

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Uname: Linux 4.4.0-18-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
Date: Mon Apr 18 18:32:24 2016
InstallCmdLine: file=/cdrom/preseed/mythbuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --- maybe-ubiquity
InstallationDate: Installed on 2016-04-18 (0 days ago)
InstallationMedia: Mythbuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160417.1)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Mike Bibbings (mike-bibbings) wrote :
Mario Limonciello (superm1) wrote :

Thanks for the report. It looks like it was detecting the package 'nvidia-340' for installation for you. This is in our CD image for mythbuntu (http://cdimage.ubuntu.com/mythbuntu/daily-live/current/xenial-desktop-amd64.list)

It is supposed to get installed directly from ubiquity's function to record_installed(). I wonder if something changed in ubiquity that's breaking this then..

        video_driver = progress.get('mythbuntu/video_driver')
        if video_driver != "Open Source Driver":
            #Install driver
            to_install.append(video_driver)

            #Build tvout/tvstandard
            out = progress.get('mythbuntu/tvout')
            standard = progress.get('mythbuntu/tvstandard')
            #Enabling xorg.conf stuff
            if 'nvidia' in video_driver:
                self.enable_nvidia(out,standard)
            else:
                self.enable_amd()

        #Mark new items
        install_misc.record_installed(to_install)

Mike Bibbings (mike-bibbings) wrote :

 Installing Nvidia 340.96 via Settings>Additional Drivers worked, Nvidia 304.131 was also available but I did not test this.

Nvidia X-server settings shows GeForce 210

Mario Limonciello (superm1) wrote :

So I think the issue here is actually libc6-i386 isn't in the live media and not a code problem.

Trying to install nvidia-340 on the media without web access requires libc6:i386 which fails, so the cache can't be marked properly.

affects: mythbuntu-live-autostart (Ubuntu) → mythbuntu-meta (Ubuntu)
Changed in ubiquity (Ubuntu):
status: New → Invalid
Changed in mythbuntu-meta (Ubuntu):
status: New → Fix Committed
Mario Limonciello (superm1) wrote :

http://bazaar.launchpad.net/~mythbuntu-dev/ubuntu-seeds/mythbuntu.xenial/revision/1271 doesn't appear to have fixed it, it's still missing in the respin.

Changed in mythbuntu-meta (Ubuntu):
status: Fix Committed → Triaged
Mario Limonciello (superm1) wrote :

From debugging it appears that this happens because libc6-i386 was promoted to the boot seed due to grub (not grub-pc) needing it.

Changed in mythbuntu-meta (Ubuntu):
importance: Undecided → High
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1571781

tags: added: iso-testing
Mario Limonciello (superm1) wrote :
Changed in mythbuntu-meta (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers