offer to create a separate /home partition

Bug #156177 reported by David Prieto on 2007-10-23
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Baltix)
Undecided
Unassigned
ubiquity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubiquity

A separate partition for /home has been proposed for a long time in the forums, due to the obvious advantages it poses → http://ubuntuforums.org/showthread.php?t=584151

It implies some risks, though, such as the risk of wasting space or running out of space if you are to use a small HD. So Ubiquity should estimate the amount of space that should be left for / or whether a separate partition should be made at all, then offer the user the option to do it through a most simple dialogue:

http://img88.imageshack.us/img88/8524/pantallazokv7.png

Where the recommended options, based on HD size, would be::

1. The default should be to create a separate /home

2A. For the default option, if the hard drive is bigger than 20 GB, and it's a Ubuntu-only installation, 10 GB should go to / and the rest should go to /home

2B. If the hard drive is between 10 GB and 20 GB, and it's a Ubuntu-only installation, 5 GB should go to / and the rest to /home

2C. If the hard drive is less than 10 GB, there should not be a separate /home partition

3A. If the hard drive is bigger than 40 GB and a dual-boot, 10 GB should go to / and the rest to /home

3B. If the hard drive is between 30 GB and 40 GB and a dual-boot, 5 GB should go to / and the rest to /home

3C. If the hard drive is less than 30 GB and a dual-boot, there should be no separate /home partition.

SPECIFICATION:

See https://blueprints.launchpad.net/ubuntu/+spec/ubiquity-preserve-home

Ralph Janke (txwikinger) wrote :
Changed in ubiquity:
importance: Undecided → Wishlist
status: New → Confirmed
Ralph Janke (txwikinger) wrote :
description: updated
The Marauder (arn-epsilon) wrote :

I wanted to report a bug, but now I'll wait :)

I just updated https://wiki.ubuntu.com/RecommendSeparateHome to propose a better integration with the existing install process.

-The first time an user installs Ubuntu, he is given the option to set a separate /home. This option is selected by default, with a size for each partition based on a sane guess:

-Of course, he can just choose not to set a separate /home. This option will be selected by default if the results of the system test suggest that's the best thing to do.

-Manual install is also possible. Selecting it greys out everything related to separate /home, since it's implied that the user doesn't want to be guided.

-If the user set a separate /home, the next time he installs Ubuntu a new option appears and is selected by default, prompting to use the existing /home partition. All other options are still available, though.

ubuntu4fun (k2osuchowski) wrote :

Duplicate of bug:
https://bugs.launchpad.net/lubi/+bug/139641

I marked my earlier bug as Invalid because this one is better explained.

See also : http://brainstorm.ubuntu.com/idea/5390/

VangelistX (vangelistx) wrote :

I think it's a very good idea. There are a few blueprints on Launchpad about it.
Compare:
https://blueprints.launchpad.net/ubuntu/+spec/home-partition-integration-with-installer
https://blueprints.launchpad.net/ubuntu/+spec/install-with-separate-home

But I would add another remark:

When you create a separate home partition (offer to) move the TEMP folder (used by default by GNOME, KDE or any other DE) on it.

If your root partition is too small (for example you have less than 4.4 GB of free space on it) you won't be able to copy or create a image of DVD, unless you change the location of the temp folder (in Brasero or K3B).

I think the TEMP folder should be placed in home partition by default as it's usually much bigger and there is no risk of lack the free space.

Evan (ev) wrote :

As the description for this bug shows, there is no way to determine a size for /home and a size for / that will suitable for all users and will not cause problems for a large subset of users down the road.

The manner in which we've implemented the ubiquity-preserve-home specification does not involve creating a separate home partition. Instead, when the user chooses to install Ubuntu on a partition without formatting it, we remove all of the system files that will be replaced during installation (so everything but /home, /opt, etc), then proceed with a regular install. This is a much safer approach, and one that does not trouble many users with concepts like partitioning that they already find confusing.

Because we have purposefully chosen to not implement a separate /home partition option for the reasons stated above, I'm marking this bug invalid. Again, I'd just like to stress that the functionality exists, just not implemented in the manner that has been suggested here.

Thanks.

Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Won't Fix

Thank You very much for the comprehensive clarification.

On Wed, 10 Jun 2009 15:40:25 +0200, Evan Dandrea <email address hidden> wrote:

> As the description for this bug shows, there is no way to determine a
> size for /home and a size for / that will suitable for all users and
> will not cause problems for a large subset of users down the road.
>
> The manner in which we've implemented the ubiquity-preserve-home
> specification does not involve creating a separate home partition.
> Instead, when the user chooses to install Ubuntu on a partition without
> formatting it, we remove all of the system files that will be replaced
> during installation (so everything but /home, /opt, etc), then proceed
> with a regular install. This is a much safer approach, and one that
> does not trouble many users with concepts like partitioning that they
> already find confusing.
>
> Because we have purposefully chosen to not implement a separate /home
> partition option for the reasons stated above, I'm marking this bug
> invalid. Again, I'd just like to stress that the functionality exists,
> just not implemented in the manner that has been suggested here.
>
> Thanks.
>
> ** Changed in: ubiquity (Ubuntu)
> Status: Confirmed => Invalid
>
> ** Changed in: ubiquity (Ubuntu)
> Status: Invalid => Won't Fix
>

cornbread (corn13read) wrote :

@Evan

There is no need to determine size for /home and for /

You simply offer to create 10 GB for root and if there is between 512MB and 1.5GB ram you offer to double that for swap and if there is 2+ you offer to equal the size for swap and just make those values changeable.

EX:
"Ubuntu recommends creating a separate /home partition, typically a user would only need 10GB space for / and XGB for swap. Would you like to use the following configuration?"
(make these user changable)
[10 GB] /
[X GB] Swap

Very straight forward and won't confuse a newb as it is ubuntu recommended.

In fact I would first greet with an option to:
1. Keep existing OS and install Ubuntu along side (as dual boot)
2. Just install Ubuntu (you will have the option to migrate your data if you choose this setting)

VERY SIMPLE AND EASILY UNDERSTANDABLE
IMO less confusing than being greeted with a large bar that is all one color and options that people don't understand. JUST TELL THEM WHAT IS RECOMMENDED FOR THE TYPICAL USER

cornbread (corn13read) wrote :

This needs to be done. I know it is just some stupid user changing this status but it really needs to get looked at and is definitely part of the 100 papercuts.

Changed in ubiquity (Ubuntu):
status: Won't Fix → New
Gijs Peskens (gijspeskens) wrote :

I completely agree in seeing the benefits of having a separate home partition, I always create one myself.
However a root which is to small (<10gb) will run into problems REALLY quick, remember a LOT of apps default to /opt (i.e. vmware images & non-free games) some stuff goes to /var (this is mostly server related though so it doesn't really count).
I would say: create the separate partition, call it a data partition or something symlink at least /opt and possibly /tmp into it and never do this on default unless / is 10gb or bigger and /home would be bigger or equal to /
The 10 gb is a number I always keep to, 5gb might be sufficient though

Evan (ev) wrote :

Please do not reopen this bug. No amount of changing its status is going to change my willingness to integrate this functionality into the installer. This is not a papercut. Papercuts are *small* *usability* bugs, of which this is neither.

It is not as simple as saying "assign 10GB to / and give the rest to /home and swap." What if the hard drive is smaller than 10GB? What if 10GB is not enough for everything they want to contain under /? We are at best wildly guessing at what the user needs. Asking them to make the determination would be dumping a problem they are potentially unequipped to handle on them. Does a computer novice need to know what a partition is? Is asking them to determine how much space they think the system will use, versus how much space their personal files will use for an operating system that they have never even used before, fair?

More to the point, what is wrong with the current implementation of allowing advanced users to install over top of a previous version of Ubuntu, deleting system files where necessary? This avoids complicated partition schemes entirely.

Changed in ubiquity (Ubuntu):
status: New → Won't Fix
cornbread (corn13read) wrote :

It is unfortunate that no ubuntu programmer is proficient enough (EXTREME SARCASM) to accomplish this task and cover all/most use cases...

"More to the point, what is wrong with the current implementation of allowing advanced users to install over top of a previous version of Ubuntu, deleting system files where necessary? This avoids complicated partition schemes entirely."

This kind of boxed thinking is what is continuing to hold linux back. Did you ever stop to think if the hard drive is smaller than 10gb to automatically go back to the current config and let those advanced users partition manually?

Also having a dialog to change these defaults with explanations of their purpose would be immensely helpful for newcomers.

You have forgotten what it is like to be a linux newb and how scary it is to install a system from scratch from their point of view. Unfortunately Evan you are partly responsible for holding newbs back.

INSTALLATION HAS TO BE SMARTER THAN THE NEWB a /home partition is smarter than none.

This comment is not meant to offend, it is mearly meant to point out the reality of the end user to someone who is probably lost sight of what an end user needs in an installer.

A current linux newb needs Simple Understandable Installation and again it "needs to be smarter than them"

Eric Appleman (erappleman) wrote :

I'd like to see this in Natty or Oneiric.

It took years for Ubiquity to get an Upgrade feature, this is the next logical step.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers