Ubiquity-DM dies on Kubuntu images

Bug #1561051 reported by Philip Muškovac on 2016-03-23
42
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Unassigned
Nominated for Xenial by Alberto Salvia Novella

Bug Description

Looks like an issue with kactivies and Qt5Sql? Or wayland?

Only seems to happen in virtual machines, not on hardware

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.51
ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
Uname: Linux 4.4.0-15-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CasperVersion: 1.368
CurrentDesktop: KDE
Date: Wed Mar 23 15:21:57 2016
InstallCmdLine: file=/cdrom/preseed/kubuntu.seed boot=casper maybe-ubiquity initrd=/casper/initrd.lz quiet splash --- maybe-ubiquity
LiveMediaBuild: Kubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
SourcePackage: ubiquity
UbiquityDebug:
 Ubiquity 2.21.51
 : Fatal IO error: client killed
UpgradeStatus: No upgrade log present (probably fresh install)

Philip Muškovac (yofel) wrote :
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1561051

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Philip Muškovac (yofel) on 2016-03-24
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-16.04
Andros83 (mail-ceandrea) wrote :

This bug prevent the installation of the OS.
Is there an alternative way to install it?

information type: Public → Public Security
information type: Public Security → Public
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
Philip Muškovac (yofel) wrote :

I don't think we've figured out what the issue is yet?

Changed in ubiquity (Ubuntu):
status: Triaged → Confirmed
Philip Muškovac (yofel) wrote :

Actually scratch that, we do know how to reproduce it now (only seems to happen in virtual machines), just not how to debug it.

Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
description: updated

The bugfix for this was released:

ubiquity (16.10.14) yakkety; urgency=medium

  * Don't need a toBool() explicit cast for the formatted toggle in KDE
    partition model.
  * Update translations from Launchpad.

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 10 Oct 2016 13:28:21 -0400

ubiquity (16.10.13) yakkety; urgency=medium

  [ Blaze ]
  * Port to PyQT5.

  [ Mathieu Trudel-Lapierre ]
  * Automatic update of included source packages: preseed 1.71ubuntu3.
  * Finish porting to PyQt5.
  * Various small UI tweaks to support GTK 3.20. (LP: #1614848, #1617711)

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 06 Oct 2016 19:30:10 -0400

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers