ubiquity crashed with GLib.GError in customize_installer(): vte-pty-error: grantpt failed: Operation not permitted (1)

Bug #1560459 reported by Dave Morley
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
glibc (Ubuntu)
Invalid
Critical
Unassigned
ubiquity (Ubuntu)
Fix Released
Critical
Adam Conrad

Bug Description

STEPS:
The current iso is horribly out of date, so using pending to test with
1. Grab the latest daily image from http://cdimages.ubuntu.com/daily-live/pending/
2. Select oem install from the uefi menu
3. Ubiquity bails out immediately

EXPECTED:
A stand oem install

ACTUAL:
deposited into desktop.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.50
ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
Uname: Linux 4.4.0-15-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CasperVersion: 1.367
CurrentDesktop: Unity
Date: Tue Mar 22 11:56:22 2016
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash oem-config/enable=true ---
LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160322)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Dave Morley (davmor2) wrote :
Revision history for this message
Dave Morley (davmor2) wrote :
tags: added: qa-daily qa-manual
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

From syslog

Mar 22 11:49:13 ubuntu ubiquity[1614]: log-output -t ubiquity apt-install oem-config-gtk oem-config-slideshow-ubuntu
Mar 22 11:49:14 ubuntu ubiquity[1614]: Exception in GTK frontend (invoking crash handler):
Mar 22 11:49:14 ubuntu ubiquity[1614]: Traceback (most recent call last):
Mar 22 11:49:14 ubuntu ubiquity[1614]: File "/usr/lib/ubiquity/bin/ubiquity", line 649, in <module>
Mar 22 11:49:14 ubuntu ubiquity[1614]: main(oem_config)
Mar 22 11:49:14 ubuntu ubiquity[1614]: File "/usr/lib/ubiquity/bin/ubiquity", line 635, in main
Mar 22 11:49:14 ubuntu ubiquity[1614]: install(query=options.query)
Mar 22 11:49:14 ubuntu ubiquity[1614]: File "/usr/lib/ubiquity/bin/ubiquity", line 264, in install
Mar 22 11:49:14 ubuntu ubiquity[1614]: wizard = ui.Wizard(distro)
Mar 22 11:49:14 ubuntu ubiquity[1614]: File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 348, in __init__
Mar 22 11:49:14 ubuntu ubiquity[1614]: self.customize_installer()
Mar 22 11:49:14 ubuntu ubiquity[1614]: File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 912, in customize_installer
Mar 22 11:49:14 ubuntu ubiquity[1614]: self.vte.spawn_sync(0, None, tail_cmd, None, 0, None, None, None)
Mar 22 11:49:14 ubuntu ubiquity[1614]: GLib.GError: vte-pty-error: grantpt failed: Operation not permitted (1)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Iain Lane (laney) wrote :

I downgraded libc6 and libc6-bin to 2.21-0ubuntu6 and this stopped happening. I had to dpkg --force --remove 'locales' too, to be able to downgrade libc6-bin.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glibc (Ubuntu):
status: New → Confirmed
summary: - Using Pending iso ubiquity crashes before the first page opens
+ ubiquity crashes before the first page opens
summary: - ubiquity crashes before the first page opens
+ ubiquity crashed with GLib.GError in customize_installer(): vte-pty-
+ error: grantpt failed: Operation not permitted (1)
Changed in glibc (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-16.03
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1560459

tags: added: iso-testing
Philip Muškovac (yofel)
tags: added: kubuntu
Revision history for this message
Iain Lane (laney) wrote :

BTW if you start ubiquity as root (sudo) with new glibc then it works.

Adam Conrad (adconrad)
Changed in glibc (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Adam Conrad (adconrad) wrote :

ubiquity (2.21.51) xenial; urgency=medium

  * ubiquity/frontend/gtk_ui.py: Drop and restore privs around calling vte.

 -- Adam Conrad <email address hidden> Tue, 22 Mar 2016 16:35:21 -0600

Changed in ubiquity (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers