Xenial: scaling is horribly out on xps13 install session

Bug #1560162 reported by Dave Morley on 2016-03-21
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
metacity (Ubuntu)
High
Iain Lane
Xenial
High
Unassigned
ubiquity (Ubuntu)
Medium
Mathieu Trudel-Lapierre
Xenial
Medium
Mathieu Trudel-Lapierre

Bug Description

STEPS:
Requirements laptop desktop with a hidpi screen (Here xps 13)
1. Grab the latest daily image and trigger an install
2. On the first page notice the of centre and over scaled window

EXPECTED:
I expect to see something resembling a normal scaled desktop install

ACTUAL:
Things are not quite correct see attached screenshots

ubiquity/xenial 2.21.49 amd64

Related branches

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Iain Lane (laney) wrote :

I got asked to look at this bug.

Happy to report that I have fixed the bulk of it, with help from Alberts Muktupāvels. The fixes are in the gnome-3-18 branch of metacity upstream too, so other people will benefit from them. And now uploaded to Xenial of course.

That fixes window placement and decoration scaling on hidpi machines, and for us in only-ubiquity mode.

There's a remaining race condition in ubiquity-dm. If you start the applets, notify-osd and so on before unity-settings-daemon has applied the scaling factor needed then some bugs happen like panel applets not showing, notification showing with large text, etc. Adding a sleep in bin/ubiquity-dm after the spawning of u-s-d works around this, but I don't know if there's a better solution such as a signal to hook into and block on. I'm assigning the ubiquity component to cyphermox to hopefully look at that. desrt might be able to advise you, maybe.

Changed in ubiquity (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in metacity (Ubuntu):
assignee: nobody → Iain Lane (laney)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:3.18.2-1ubuntu3

---------------
metacity (1:3.18.2-1ubuntu3) xenial; urgency=medium

  * debian/patches/0001-gradient-sync-code-with-mutter-before-it-was-removed.patch,
    debian/patches/0002-theme-scale-window-decorations-on-HiDPI-displays.patch,
    debian/patches/0003-gradient-sync-code-with-mutter-before-it-was-removed.patch:
    Cherry-pick patches from upstream to fix window placement and decoration
    drawing on HiDPI systems. (LP: #1560162)

 -- Iain Lane <email address hidden> Thu, 24 Mar 2016 17:16:26 +0000

Changed in metacity (Ubuntu):
status: Fix Committed → Fix Released
Kent Lin (kent-jclin) on 2016-06-24
Changed in oem-priority:
importance: Undecided → High
Ara Pulido (ara) on 2016-06-29
Changed in metacity (Ubuntu Xenial):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 16.10.5

---------------
ubiquity (16.10.5) yakkety; urgency=medium

  [ Kai-Heng Feng ]
  * ubiquity-dm: Wait until u-s-d xsettings plugin is activated. (LP: #1560162)

  [ David Jordan ]
  * ubiquity/misc.py: set correct target device name for nvme drives.
    (LP: #1600308)

  [ Mathieu Trudel-Lapierre ]
  * ubi-prepare.py: default to Secure Boot disabled if we install third-party
    drivers.

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 25 Jul 2016 15:37:04 -0400

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
Changed in ubiquity (Ubuntu Xenial):
status: New → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)

Hello Dave, or anyone else affected,

Accepted ubiquity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubiquity/2.21.63.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in metacity (Ubuntu Xenial):
importance: Undecided → High
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Changed in metacity (Ubuntu):
importance: Undecided → High
Changed in ubiquity (Ubuntu Xenial):
importance: Undecided → Medium

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of ubiquity from xenial-proposed was performed and bug 1624321 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1624321 (not this bug). Thanks!

tags: added: verification-failed
Jerry Kao (jerry.kao) wrote :

This issue is happening in OOBE. Enable -proposed then update is only available after boot into OS.

This still needs verification. You would want to use 'break=bottom' on the command-line when booting to stop before ubiquity starts, then chroot into the system and apt-get install the new ubiquity to test this.

The bug that was automatically found isn't a regression of this fix but an issue with debconf-apt-progress unrelated to the problem at hand.

tags: removed: verification-failed

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of ubiquity from xenial-proposed was performed and bug 1631652 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1631652 (not this bug). Thanks!

tags: added: verification-failed
Nara Huang (narahuang) wrote :

Using ubiquity 2.21.63.3, I cannot reproduce this issue.

tags: added: cqa-verified
removed: verification-failed verification-needed

Since it's been verified by Nara; marking verification-done.

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.63.3

---------------
ubiquity (2.21.63.3) xenial; urgency=medium

  * ubi-prepare.py: default to disabling Secure Boot when third party drivers
    are being installed, since it's most likely what people will want. This
    will also avoid people skipping through this important part of the
    installer without noticing, only to find their systems not all working
    correctly. (LP: #1606393)
  * d-i/sources.list: add xenial-updates to sources.list to pick up any SRUs
    of d-i components that are no longer in flight.
  * Automatic update of included source packages: apt-setup
    1:0.104ubuntu4.1, base-installer 1.158ubuntu2.1, netcfg
    1.135ubuntu4.1. (LP: #1590358)
  * bin/ubiquity-dm: wait for the DBus signals telling us that xsettings are
    ready before continuing with preparing ubiquity-dm; this avoids starting
    too quickly and incorrectly applying scale ratios for HiDPI screens.
    (LP: #1560162)

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 02 Sep 2016 11:17:13 -0400

Changed in ubiquity (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubiquity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Yuan-Chen Cheng (ycheng-twn) wrote :

base on current status, mark it fix release on oem-priority. re-open if it's not apply to you.

Changed in oem-priority:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers