Ubiquity installer crashes when there is a non-accessible folder in a partition

Bug #155156 reported by Sergio Costas on 2007-10-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Every time I tried to install Ubuntu 7.04 or 7.10 in my system it failed with a Crash message (in the upper bar). After trying a lot of things, I found that the bug was because there was a non-accesible folder in the partition I wanted to use as /home.

I was reinstalling my system due to some problems, and I wanted to maintain all my /home data, and some configuration files (my firewall and some other ones), so I copied (as root) the /etc folder to /home before starting the installation. The folder had "root" as owner and group.

Then I tried to install Ubuntu 7.04, but it crashed after choosing the partitions. With Ubuntu 7.10 it was similar, but it crashed at 92% of the installation. I tried to mount the partitions in another order, and even to not mount /dev/sda6, but the installer always mounted it. After a lot of tests, I found that it was the "Migration assistant" (I'm not sure if this is the right name, since I use the spanish version. I'm talking about the assistant which allows you to migrate an old account into a new one) the one who was crashing.

Finally I found that the problem was that folder with "root" as owner and group. Just changing the user and group, and moving it to another folder fixed the problem, and allowed me to complete the installation without crashes.

I forgot to comment that I used the live-CD installers in both cases.

I think my explanation was too obscure to be understood. I'll try to make it better:

I have three partitions in my hard disk:

sda1 for /
sda5 for swap
sda6 for /home

I had some problems with my system and decided to reinstall it, but preserving my /home data and some config files, so before starting the installation process I did:

    sudo cp -r /etc /home

to make a copy of the /etc folder and preserve all my configuration files. Then I booted the Gutsy Live-CD (7.10) and chose sda1 for / (formating it), sda5 for swap, and sda6 as /home (not formating, of course). The installation started fine (but never asked me to migrate old accounts), but when it reached 92% it failed: the window just dissapeared.

I tried it again putting sda6 in other points, not mounting it... but always failed in the same point. (The installer mounted it always, even when I specified to not mount it). Then I tried with Feisty (7.04) and it failed again, but just after the partitioning section. But 6.10 worked fine.

Finally I found that the problem was the copied /etc folder in /home (sda6). It had root as owner and group. When I moved it into the account's folder, the Gutsy installation worked fine, even asking me if I want to migrate the account folder.

Hope that now the problem is more clear.

From the duplicate: This is a confirmed problem in Hardy. Unfortunately I do not have an available system to be able to test this, so if possible can you a) confirm this is a problem in the latest release, i.e. Jaunty and, b) attach /var/log/syslog and /var/log/partman to this bug, following the directions in http://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs ? Thank you in advance.

Changed in ubiquity (Ubuntu):
status: New → Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in ubiquity (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers