ubiquity crashed with UnicodeDecodeError in decode(): 'ascii' codec can't decode byte 0xc5 in position 8782: ordinal not in range(128)

Bug #1551285 reported by richud on 2016-02-29
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
localechooser (Ubuntu)
High
Mathieu Trudel-Lapierre
ubiquity (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

using automated install from seed file on 16.10 pxe booted via NFS
Seed file works on last half dozen versions without issue.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.47
ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
Uname: Linux 4.4.0-8-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
Date: Mon Feb 29 15:23:25 2016
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InstallCmdLine: BOOT_IMAGE=/os/ubuntu/16.04amd64/casper/vmlinuz.efi noprompt root=/dev/nfs netboot=nfs nfsroot=143.210.24.235:/os/ubuntu/16.04amd64 url=http://143.210.24.235/os/ubuntu/autoinstall.seed boot=casper initrd=/os/ubuntu/16.04amd64/casper/initrd.lz automatic-ubiquity
InterpreterPath: /usr/bin/python3.5
ProcCmdline: /usr/bin/python3 /usr/lib/ubiquity/bin/ubiquity --automatic --only
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/2691/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', '--automatic', '--only']
SourcePackage: ubiquity
Title: ubiquity crashed with UnicodeDecodeError in decode(): 'ascii' codec can't decode byte 0xc5 in position 8782: ordinal not in range(128)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

richud (richud.com) wrote :
tags: removed: need-duplicate-check
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Ara Pulido (ara) on 2016-03-18
Changed in ubiquity (Ubuntu):
importance: Medium → High
Taihsiang Ho (taihsiangho) wrote :

Both of March 23rd and March 30th daily build could still reproduce this issue.

Could you share the preseed? It would be useful to reproduce the bug; which I can't seem to get otherwise.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
information type: Private → Public
richud (richud.com) wrote :

Hi Mathieu, emailed preseed to the reply-to and directly to your gmail on Fri 1st April, hope you got it ok?

Taihsiang Ho (taihsiangho) wrote :

I could reproduce this issue with my preseed.
However, if I remove the part of language and keyboard selection of the preseed, and then manually selecting they as English,
this issue could not reproduce and the system would be installed successfully via PXE.

Here is what I removed:

## Locale sets language and country.
#d-i debian-installer/locale string en_US
#
## Keyboard selection.
## Disable automatic (interactive) keymap detection.
#d-i console-setup/ask_detect boolean false
#d-i keyboard-configuration/ask_detect boolean false
##d-i console-setup/modelcode string pc105
#d-i console-setup/layoutcode string us
#d-i keyboard-configuration/layoutcode string us
## To select a variant of the selected layout (if you leave this out, the
## basic form of the layout will be used):
##d-i console-setup/variantcode string dvorak

Taihsiang Ho (taihsiangho) wrote :

Sorry for the unclear statement above.
I mean, removing that section of the preseed I used could not reproduce this issue anymore (so I add comment # to remove the section)

I found the issue in localechooser, I will fix it now.

Changed in ubiquity (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Changed in localechooser (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package localechooser - 2.65ubuntu4

---------------
localechooser (2.65ubuntu4) xenial; urgency=medium

  * localechooser: Use grep -a to make sure grep sees our language list data
    as ASCII and not random binary since it contains some glyphs for language
    name translations. Fixes at least one crash in Ubiquity. (LP: #1551285)

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 13 Apr 2016 10:04:25 -0400

Changed in localechooser (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.57

---------------
ubiquity (2.21.57) xenial; urgency=medium

  [ Mathieu Trudel-Lapierre ]
  * Automatic update of included source packages: localechooser
    2.65ubuntu4. (LP: #1551285)
  * scripts/simple-plugins: better handle passing the MokPW key to mokutil
    and the result from the command -- we explicitly can ignore errors here.
    (LP: #1567445)
  * plugin-viewer-gtk.py: fix plugin-viewer-gtk to allow showing most plugins
    correctly; useful for debugging.
  * ubiquity/plugins/ubi-prepare.py: rework password validation behavior for
    MokPW without changing user-visible strings: we only need to show feedback
    for a "good" password (of the allowable lengths), and correct the behavior
    for mismatched passwords. Also make it obvious if the chosen password is
    too short. (LP: #1560940)

  [ Shih-Yuan Lee (FourDollars) ]
  * Really make oem-config-prepare quiet when started by a non-priviledged
    user.

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 13 Apr 2016 14:36:37 -0400

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers