Ubiquity throws up a ubi-prepare error when using uefi and secureboot

Bug #1549277 reported by Dave Morley on 2016-02-24
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

Will attach syslog, but basically got a message from ubiquity saying it had failed to run ubi-prepare.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.44
ProcVersionSignature: Ubuntu 4.4.0-6.21-generic 4.4.1
Uname: Linux 4.4.0-6-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CasperVersion: 1.367
Date: Wed Feb 24 12:27:07 2016
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---
LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160223)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

From syslog mokutil is missing

Feb 24 12:05:41 ubuntu ubiquity: Setting up intel-microcode (3.20151106.1) ...
Feb 24 12:05:41 ubuntu ubiquity:
Feb 24 12:05:41 ubuntu ubiquity: update-initramfs is disabled since running on read-only media
Feb 24 12:05:41 ubuntu ubiquity:
Feb 24 12:05:41 ubuntu ubiquity: intel-microcode: microcode will be updated at next boot
Feb 24 12:05:41 ubuntu ubiquity:
Feb 24 12:05:42 ubuntu ubiquity: sudo
Feb 24 12:05:42 ubuntu ubiquity: :
Feb 24 12:05:42 ubuntu ubiquity: mokutil: command not found

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
Changed in ubiquity (Ubuntu):
assignee: Ubuntu Installer Team (ubuntu-installer) → Mathieu Trudel-Lapierre (mathieu-tl)

Should be fixed now that we include mokutil on the image.

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers