ubiquity crashed with dbus.exceptions.DBusException in call_blocking(): org.freedesktop.DBus.Error.InvalidArgs: No such interface '/org/freedesktop/UPower'

Bug #1547956 reported by sasidhar79 on 2016-02-20
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Martin Pitt
Xenial
Critical
Martin Pitt

Bug Description

this happens while booting from usb disk running 16.04 installed

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.44
ProcVersionSignature: Ubuntu 4.4.0-6.21-generic 4.4.1
Uname: Linux 4.4.0-6-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CasperVersion: 1.367
Date: Sat Feb 20 21:04:53 2016
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --- maybe-ubiquity
InterpreterPath: /usr/bin/python3.5
LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160219)
ProcCmdline: /usr/bin/python3 /usr/lib/ubiquity/bin/ubiquity --greeter --only
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/2415/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', '--greeter', '--only']
SourcePackage: ubiquity
Title: ubiquity crashed with dbus.exceptions.DBusException in call_blocking(): org.freedesktop.DBus.Error.InvalidArgs: No such interface '/org/freedesktop/UPower'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

sasidhar79 (sasidhar79) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1547518, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
information type: Private → Public
Martin Pitt (pitti) on 2016-02-24
Changed in ubiquity (Ubuntu):
importance: Medium → Low
importance: Low → Critical
Changed in ubiquity (Ubuntu Xenial):
milestone: none → ubuntu-16.01
status: New → In Progress
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

This was supposed to be fixed by http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk/revision/6376, but this is a really bad fix. Also, version 2.21.45 with that fix is FTBFS.

I committed a proper fix in http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk/revision/6379.

Changed in ubiquity (Ubuntu Xenial):
status: In Progress → Fix Committed
sudodus (nio-wiklund) wrote :

When will it trickle down to the xenial daily (now beta 1) iso files? Today :-P

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1547956

tags: added: iso-testing
A. Richard Miller (themillers) wrote :

Today's new Ubuntu 16.04 daily-live for xenial-desktop-amd64.iso still runs okay live (but w/o Ubuntu Software Center or other way to add System Load Indicator), and still fails to install Ubuntu to disk (SSD) with same UPower error message.

My test computer is a Dell i3147-3750 netbook.

Martin Pitt (pitti) on 2016-02-24
Changed in ubiquity (Ubuntu Xenial):
milestone: ubuntu-16.01 → ubuntu-16.02
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.46

---------------
ubiquity (2.21.46) xenial; urgency=medium

  * ubiquity/upower.py: Revert commit 6376, blank "except:" is wrong.
  * ubiquity/upower.py: Actually specify the correct D-Bus interface name
    instead of the object path name when querying the OnBattery property.
    (LP: #1547956)
  * debian/rules: Build under C.UTF-8 locale. grep 2.23 causes broken debconf
    templates to be built under the C locale.

 -- Martin Pitt <email address hidden> Wed, 24 Feb 2016 16:02:19 +0100

Changed in ubiquity (Ubuntu Xenial):
status: Fix Committed → Fix Released
varlesh (varlesh-l) wrote :

Confirm, new version fixed.
sudo apt-get update
sudo apt-get install --reinstall ubiquity
Install OS

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers