ubiquity crashed with dbus.exceptions.DBusException in call_blocking(): org.freedesktop.DBus.Error.InvalidArgs: No such interface '/org/freedesktop/UPower'

Bug #1547518 reported by howefield on 2016-02-19
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
ubiquity
New
Undecided
Unassigned
ubiquity (Ubuntu)
Critical
Mathieu Trudel-Lapierre

Bug Description

STEPS TO REPRODUCE
Using a 16.04 image, either select install from the GRUB menu or load the live environment and click the install icon on the Desktop.

EXPECTED RESULTS
Installer loads normally.

ACTUAL RESULTS
Installer crashes with dbus.exceptions.DBusException in call_blocking(): org.freedesktop.DBus.Error.InvalidArgs: No such interface '/org/freedesktop/UPower'

AFFECTS
 * only affects bare metal with a battery
 * amd64 and i386 architectures
 * 16.04 ubiquity (not debian-installer) images from 19 February 2016 on
 * ubiquity 2.21.44
 * Linux 4.4.0-6

WORKAROUND
 * remove the battery before installing
 * also patch: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1547518/comments/3

howefield (howefield) wrote :
tags: removed: need-duplicate-check
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Pasi Lallinaho (knome) on 2016-02-22
information type: Private → Public
Christopher Bayliss (cjbayliss) wrote :

Based on the comment by Nikola Kovacson on the duplicate bug 1547860 (https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1547860/comments/4), this attachment works (but is a hack):

The attachment "upower.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
ek0892 (kranich) wrote :

I test with 5 notebooks :

 If remove battery , install is OK

but with battery inside + AD/DC power , ubiquity Crash !

sudodus (nio-wiklund) wrote :

This bug seems to affect Lubuntu i386 - the iso-testing testcases which include installing. I would say it is a red bug.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1547518

tags: added: iso-testing
sudodus (nio-wiklund) wrote :

This bug seems to affect Lubuntu i386 - the iso-testing testcases which include installing. I would say it is a *red* bug.

Tested in my Toshiba with Intel i5

http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

Changed in ubiquity (Ubuntu):
importance: Medium → Critical
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
sudodus (nio-wiklund) wrote :

This bug does not affect a desktop computer with the following motherboard

http://www.asus.com/Motherboards/M2NVM_DVI/

So it seems to affect (only?) computers with batteries.

howefield (howefield) wrote :

Many thanks ek0892 (kranich)

Removing the battery for the installation process enabled to install to go ahead.

Paul White (paulw2u) wrote :

Just tested with Xubuntu 64-bit - removing battery allowed the install process to start

Walter Lapchynski (wxl) on 2016-02-22
description: updated
Walter Lapchynski (wxl) on 2016-02-22
description: updated
description: updated

Possible cause of this error is this upowerd crash
https://bugs.launchpad.net/ubuntu/+source/upower/+bug/1548524

Nairwolf (nairwolf) wrote :

I've tested with Xubuntu 64-bit, like paulw2u, ubiquity crashes with a battery, and when I'm removing the battery, the installation starts correctly.

Matthew Lonis (mattlonis) wrote :

This bug is also affecting me when installing Lubuntu on my Dell XPS 13 9350 (USING 64 BIT)

lxj616 (502307678-f) wrote :

Also affect virtualbox on my notebook (with battery) , ubuntu-gnome 16.04 daily 20160222 (tried 20160222.2 , still not working)

Walter Lapchynski (wxl) wrote :

@lxj616, if you remove the battery and run on AC power, will the VM work?

A. Richard Miller (themillers) wrote :

This also seems to be our complaint on the Dell Inspiron 3147-3750 2-in-1 netbooks here. The dailies have been failing to begin installation since Feb. 17th or 18th - when they also lost the Ubuntu Software Center. (I find it helpful to run the System Load Indicator during an Ubuntu installation.)

The problem still exists as of Feb. 22nd. Testing without battery would be painful here, as the battery is internal on this model - and on many other models, these days.

Big thanks to those who are working on this fix!

Martin Pitt (pitti) wrote :

This is almost surely a duplicate of bug 1547793, so I'll mark it as such for now, and we'll re-test with the fix.

ek0892 (kranich) wrote :

For me with upower - 0.99.4-2 the problem is not solve.

I test with 5 notebooks :

 If remove battery , install is OK

but with battery inside + AD/DC power , ubiquity Crash !

Anca Emanuel (anca-emanuel) wrote :

I also tested the workaround, to remove the battery from the laptop (https://www.msi.com/product/notebook/GX600.html). It works...
Now, who is to blame for poor coding ?

Marc (mrt-bills) wrote :

Experiencing this bug using VirtualBox 5.0.14 using the 64-bit AMD image for Feb 24-2016.
My host machine is a MacBook Pro 13" (Late 2013) running OS X 10.11.3. It does not matter if the system is plugged into the AC power or running on battery -- same issue of this problem occurring before the interactive installer program should appear. System boots into graphically mode and a few seconds later the error message appears. Please fix soon since using VirtualBox environment is my preference. Note that no issue with same build using VMware Fusion 8.1.

Marc (mrt-bills) wrote :

Feb 23-2016 DVD image I should have stated.

Changed in ubuntukylin:
milestone: none → xenial-beta1
no longer affects: ubuntukylin
ek0892 (kranich) wrote :

Ok Thank, I wait.

it's not possible update Ubiquity 2.21.45 for Upower 0.99.4-2

because "build error" : https://launchpad.net/ubuntu/+source/ubiquity/2.21.45

A. Richard Miller (themillers) wrote :

Today's new Ubuntu 16.04 daily-live for xenial-desktop-amd64.iso still runs okay live (but w/o Ubuntu Software Center or other way to add System Load Indicator), and still fails to install Ubuntu to disk (SSD) with same UPower error message.
Computer is Dell i3147-3750 netbook.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers