16.04 installer can't get past "Force UEFI installation"

Bug #1547286 reported by Thomas Mashos on 2016-02-19
116
This bug affects 28 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Unassigned

Bug Description

Ubuntu 16.04 Daily

I have a new 500GB SSD and no other drives attached. I'm installing only Ubuntu on this bare drive, so I'm not sure why this is popping up but it's two issues. My computer is set to UEFI only mode and this only happens when I select "Something Else" in order to setup manual partitioning.

What happens:
1) "Force UEFI installation?" pops up even though this is a bare drive without anything else on it. I did attempt to dd a 250GB SSD to it, but that failed so I wiped the drive.

2) I cannot get past this Force UEFI page. Neither the "Go Back" nor the "Continue" button do anything.

What is expected to happen:
Either don't pop up this message since I've no other OS installed, or clicking the "Go Back" button should go back and the "Continue" button should force the UEFI installation.

On a side note, this screen says "If you continue to install Debian in UEFI mode, " which should probably say Ubuntu instead of Debian.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.43
ProcVersionSignature: Ubuntu 4.4.0-4.19-generic 4.4.1
Uname: Linux 4.4.0-4-generic x86_64
ApportVersion: 2.20-0ubuntu2
Architecture: amd64
CasperVersion: 1.366
CurrentDesktop: Unity
Date: Fri Feb 19 01:46:50 2016
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---
LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160216)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Thomas Mashos (tgm4883) wrote :
Thomas Mashos (tgm4883) wrote :
Thomas Mashos (tgm4883) wrote :
Thomas Mashos (tgm4883) on 2016-02-19
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Somewhere over the.. (nemonein) wrote :

I have downloaded March 7th version of Ubuntu, 64bit.
It's the same as Thomas Mashos described.

Somewhere over the.. (nemonein) wrote :

I'm not quite sure about this.
If I choose 'Try Ubuntu' and then choose 'Instal', this bug pops up.
If I choose directly 'Install Ubuntu' on a text based Ubuntu Boot up screen, everything is fine.

Somewhere over the.. (nemonein) wrote :

I'm sorry.
It was my mistake.
If choose 'Install Ubuntu', and Ubuntu is installed in BIOS mode, not UEFI mode.

Marc Pignat (swid) wrote :

JH Park,

I faced the same problem, which partitioning method did you use?

I used manual partitioning, perhaps a duplicate of #1447256 ?

Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
Phillip Susi (psusi) wrote :

It looks like you did not create an EFI system partition. While it should not give this message and freeze, you do need to create one to install successfully.

Buzzing Robot (buzzingrobot) wrote :

Seeing this today in a Mate 16.04 install, with both the third-party and updates options selected. UEFI mode, with correct partitioning.

Fabien (id-ubuntu) wrote :

The computer had 1xSSD + 1xRAID1of2xHDD and i'm using manual partitionning.
What i do :
-create new PT on the SSD and the RAID,
-add EFI part on the SSD,
-add parts i need on both disks.
-next and the pop-up...

I've finally have my fresh install, with this method :
-create new PT on each disk,
-add FAT32 part on the SSD (NOT EFI),
-add parts you need on disks,
-next and a pop-up about the missing EFI -> go back,
-select the first FAT32 part mensioned above, modify to EFI,
-next and install :)

Hope this helps...

Tobias Brandt (snth) wrote :

Same problem here on an HP Z420 with a 240GB SSD as the boot device and some other data drives attached.

Tried to install with manual partitioning and the following partitions:
  * 1 GB EFI System on sdc1
  * 48 GB swap on sdc2
  * rest (191 GB) on sdc3 with ext4

After the manual partition and confirming the new partition setup it then proceeds to say that it has detected non-UEFI systems and asks whether I want to Force the UEFI installation. At that point both the "Go Back" and "Continue" buttons are unresponsive. After that the background changes to the World Map to select the timezone but it's not in focus. I left it on overnight to check if maybe it was doing some formatting or something in the background but the next morning it was still stuck on the same screen.

Nick Piepmeier (nick-pieps) wrote :

Fabien's workaround in #11 worked for me.

gianttu (gianttu) wrote :

I purchases HP EliteDesk 800 G2 mini and face the same issue, follow the workaround #11 and installation continues, thanks Fabien!

Chazall1 (lishdigg) wrote :

I have the same problems as everyone here on the daily Ubuntu-Gnome 16.10 as well as many of the past daily releases for the past week. The installer has my non ssd drives 2. I followed #11 and got no further. I have 3 other linux installs on my ssd. I have bios set up correctly I have no boot issues to any OS including WIN on one drive. This is the first time in many years that I have had this issue (very frustrating) that I can NOT install another OS to test. I have tried both 32 and 64 .iso's . I have run parted -l and my ssd is not listed, same from my USB installer, I select Something else to choose where I want to install, NO SSD listed.

Joe (joelightshoe) wrote :

this explains that it is related to selecting "Download updates while installing" prior to installation.

http://askubuntu.com/questions/693732/window-stuck-on-force-uefi-installation-window

Reuben Firmin (reubenf) wrote :

Can confirm, this is related to "Download updates". Without this option selected (and wifi off, if that matters), you still get the dialog, but this time the buttons are functional.

Note, this bug is _not_ a duplicate of #1418706 -- I encountered it on a brand new Dell laptop with Windows 10 on the drive, so it has nothing to do with the drive being blank.

Clancy Childs (clancy) wrote :

I had this problem but was able to get around it by making sure WiFi was disabled before starting the installer and not checking the download box.

Lingqian Meng (binyi1114) wrote :

yes, disable WiFi at first. It works.

dxtr101 (dxtr101456) wrote :

Short answer: I was able to fix this issue by plugging my hard drive into another SATA connection on the motherboard.

Long answer: I tried potential fixes listed in responses 11, 17, and 18 but it still didn't work. Gparted recognized the drive, but wouldn't allow me to create a partition table or format due a sych failure. I had issues in the past with some of the SATA connections on the motherboard before (ASUS M4A89TD Pro Series) so I just moved the connection from 5 to 0 (there are 6 connections directly on the motherboard). Not sure of the underlying cause for other users, but for me it was the SATA connection or BIOS setting on the motherboard preventing me from formatting or partitioning the hard drive but still allowing Ubuntu to recognize it was there.

Liviu Chircu (liviuchircu) wrote :

Had the "stuck Back/Continue buttons" problem on a new Z370 rig. I did not get to try #11 or #16 yet. What fixed it for me was realizing that the USB stick was still auto-booting into UEFI mode (with CSM support fully enabled), hence altering the whole Xubuntu 16.04 installation process!

As soon as I explicitly booted from the USB in Legacy mode using the boot menu (F12), the installer had no more problems creating the legacy, MBR-based partitions I originally wanted it to do.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers