Ubuntu LiveCD "Install" icon confusing

Bug #154506 reported by Ryan Prior on 2007-10-19
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Humanity
Undecided
Unassigned
One Hundred Papercuts
Low
Unassigned
ubiquity (Ubuntu)
Wishlist
Unassigned
Declined for Hardy by Henrik Nilsen Omma
Declined for Jaunty by Henrik Nilsen Omma

Bug Description

Binary package hint: ubiquity-frontend-gtk

Yesterday I watched a number of people using Ubuntu Gutsy LiveCDs on their computers. They were confused by the "Install" icon on the desktop.

One user cleverly downloaded a .deb file from a website and drag-dropped it onto the "Install" button. He was thrown off when the computer did not respond as he had expected -- he thought it would install that program onto the computer, like when you drag an app from a DMG package to the Applications folder in Mac OSX.

A few other users were confused in a different way, clicking Install in order to find new programs to install. They were not expecting to begin the *Ubuntu* install process -- they just wanted to see what programs were available. Because the Install button is more prominent than the Add/Remove button on the Ubuntu LiveCD, they went for the Install button right away.

I think that this represents a bug in the Ubiquity user interface, and I would like to see a change.

I propose, for starters, renaming the icon "Install Ubuntu to Hard Drive" instead of the vague "Install". You might also think about moving it somewhere else, so that it isn't one of the scarce few icons on the LiveCD desktop. I know that you want to make installation easy, but right now it's also confusing to many new users.

I second this comment. Simple "Install" is frankly too simple :) It is confusing.

Brian Murray (brian-murray) wrote :

Reviewing this bug report and its comments it seems that multiple people have this sentiment. Subsequently, I am confirming this bug report. For future reference you can manage the status of bug reports by clicking on the current status in the yellow line and then choosing a new status in the drop down box. You can learn more about bug statuses at http://wiki.ubuntu.com/Bugs/Status .

Changed in ubiquity:
importance: Undecided → Wishlist
status: New → Confirmed
Dries Desmet (dries) wrote :

I share the opinion of this bug reporter.

Colin Watson (cjwatson) wrote :

I was asked to make the text short in order that descriptions of how to install Ubuntu would fit neatly onto the text on the CD sleeves.

Changed in ubiquity:
status: Confirmed → Triaged
Ryan Prior (ryanprior) wrote :

So, now that we have an "install Ubuntu to hard drive" option in GRUB, perhaps we can get rid of the desktop icon in the LiveCD?

I don't think that would be a good idea, because people might want to have a look at ubuntu on the liveCD before actually installing. When it comes to installing, they could have a problem finding the right place to go to install if there is not a prominent icon on the desktop.

Ryan Prior (ryanprior) wrote :

Thanks for your comment, David. I agree that a prominent desktop icon should be present. However, I think that a few more icons should be placed on the desktop (that lone solitary icon seems a lot more out of place than it does if you add links to Examples and and Help.) In addition, the name "Install" is very vague, whereas "Install Ubuntu to hard drive" would be much clearer.

Michael Budde (mbudde) wrote :

What about "Install Ubuntu" if it should remain short? Perhaps that is still a bit too vague...

Mat Tomaszewski (mat.t.) wrote :

Excellent example of a papercut. My call would be to rename it to "Install Ubuntu on this computer". Any other suggestions welcome.

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed

I think "Install Ubuntu" is great. "on this computer" is superfluous, as I am pretty sure nobody could be confused about which computer Ubuntu would be installed on if they click the icon.

Changed in hundredpapercuts:
milestone: none → round-3
Martin Karlsson (foh1981) wrote :

I agree with Ryan's first comment. Maybe the Install icon/option could be placed under the System menu (after all, it's system related right?) among the Help and About items. I believe that there's a whole group of people using LiveCDs for common tasks, and that never intend to install the system to hard drive. I believe that there should be a balance between that sort of use and the current "I'll just check it out and maybe even install it" sort of thing. I think this icon naming issue is primarily one of too little information.

Personally I think it would be nice to have a Welcome dialogbox, explaining the function of the LiveCD (that you can try the system a bit etc) and where to find the Install option (under the System menu) in just a few sentences. Just placing an icon on the desktop so that users really can't miss it seems sort of... I don't want to say lazy, but it's kinda saying "Find out on your own". Maybe the icon should be replaced with a small document describing the procedure?

That could be a bit too much of course. I'm mostly throwing things out there, but there needs to be a balance between simplicity and information.

Catto (catto) wrote :

When i read the suggestions "Install Ubuntu" or "Install Ubuntu to hard drive" i am asking myself why the
Word "Ubuntu" is in it. Of course this icon would install Ubuntu - what else ?

I think "Install to hard drive" is a good choice.

Maybe there are some really unexperienced users that are not so familar with the word "install".
( Non-native english speakers. )
They would get a better understanding of the programm behind the icon if the Icon would be "Copy CD to my hard drive".
As a technician i think the word "install" is necessary.

Twig (pfirth) wrote :

I think it would be a good idea to add a sense of a permanent change. I suggest something like "Permanently Install Ubuntu" or "Install Ubuntu Permanently". I favour the first one as it scans better.

Evan (ev) wrote :

Catto,

You can install more than the operating system in the live CD environment, and that's what the initial comment suggests leads to confusion.

I think "Install to hard drive" or "Install Ubuntu to hard drive" are too verbose and are inaccurate. You can install Ubuntu to a USB disk, which I believe is not what users think of when they hear "hard drive".

Ryan Prior (ryanprior) wrote :

Catto,

The user can also install software (packages), and many users don't understand the difference between a LiveCD and a hard-drive install (nor should they have to).

I very much like Mat's suggestion, "Install Ubuntu on this computer": it assumes no level of technical knowledge and leaves no ambiguity as to what launching that process will do. Absolute newbies may not understand the word "install", but those users are very likely to have help from somebody with at least a small amount of experience who will recognize that verb.

Vish (vish) wrote :

How about making it more release specific,
"Install Ubuntu 9.10" ,
and so on...

Adding "On this computer" seems to be making it too simple , almost like teaching a toddler.

mac_v: but that's the case! It should be simple, and it should be understandable to everyone who tries to get it.

I would like to second 'Install Ubuntu on this computer'.

Changed in humanity:
assignee: nobody → Daniel Fore (daniel-p-fore)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.99.0

---------------
ubiquity (1.99.0) karmic; urgency=low

  [ Michael Terry ]
  * Merge oem-config code into ubiquity.
    - Adds several new binary packages (oem-config, oem-config-gtk,
      oem-config-kde, oem-config-debconf, oem-config-check, and
      oem-config-udeb).
    - Various architectural changes as well, including support in various
      places for running in 'oem user config' mode. Which is when the user is
      configuring an already-installed system after opening it (i.e. when run
      as the binary 'oem-config'.
    - Baby-step support for preseeding different page sequences.
  * Automatic update of included source packages: debian-installer-utils
    1.70ubuntu1, user-setup 1.27ubuntu4.

  [ Evan Dandrea ]
  * Remove code to account for last-good-boot in oem-config-firstboot as
    the former has been abandoned.
  * Add a RELEASE marker in the desktop file to be substituted for the
    release name and version by casper (LP: #154506).
  * Automatic update of included source packages: grub-installer
    1.39ubuntu1, partman-auto 87ubuntu1.

 -- Evan Dandrea <email address hidden> Wed, 15 Jul 2009 15:06:57 +0100

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
Matthew Paul Thomas (mpt) wrote :

FWIW, "Install Ubuntu Permanently" was exactly what I specified in the initial Ubiquity design in 2006. <https://wiki.ubuntu.com/UbuntuExpress/GnomeUserInterface#Invocation%20and%20overall%20design>

Colin Watson (cjwatson) wrote :

And, for the record, that was changed from your original design for the reasons I gave in comment 4. Apparently the text under the icon is no longer mentioned on the CD sleeve so that's no longer an issue.

Igor Vatavuk (igor-vatavuk) wrote :

This "fix" created another problem, now the ubiquity launcher in menu (System>Administration) says "Install RELEASE".

Confirming Igor's comment for latest Karmic daily. Setting bug status back to Confirmed because of that.

Changed in ubiquity (Ubuntu):
status: Fix Released → Confirmed
Andrew (and471) wrote :

This has been fixed, can confirm the launcher now says

"Install Ubuntu 9.10"
 with tooltip
"Install this system permanently to your hard disk"

in Alpha-4 (screenshot attached), setting bug as fixed.

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
Vish (vish) wrote :

Not an icon theme bug

Changed in humanity:
assignee: Daniel Fore (daniel-p-fore) → nobody
status: New → Invalid

While it looks like I'm a bit late, I'd strongly suggest making the launcher distro-neutral such as "Install to Hard Drive" rather than mention Ubuntu specifically. Otherwise downstream distros will have to fork Ubiquity just to change the branding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments