Slideshow output in different font when install in Japanese. (16.04)

Bug #1540063 reported by BALLOON a.k.a. Fu-sen. (Keiichi SHIGA) on 2016-01-31
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Medium
Gunnar Hjalmarsson
ubiquity (Ubuntu)
High
Unassigned

Bug Description

I was to proceed to install the Ubuntu MATE 16.04 Alpha 2 in Japanese (日本語).
After the installation work, Japanese view of the slide show has encountered a problem that changes in Serif Font.
It might have been output in the Chinese font.

I also tried in other flavors, as a result, even with the same problem occurs Ubuntu Desktop Image 16.04 Daily Build.
it does not seem to reproduce all of the flavors, Xubuntu and Lubuntu are output normally.

tags: added: xenial
affects: ubiquity-slideshow-ubuntu (Ubuntu) → ubuntu-translations
Changed in ubuntu-translations:
status: New → Confirmed
Kenichi Ito (ken-i54k) wrote :

I can't reproduce in a live session.
But that reproduced in the first screen "Install (as superuser)" on starting.

Yuan Chao (yuanchao) wrote :

It looks like some "kai" type (traditional?) Chinese font is picked up instead of the "ゴシック" type (sans) specific? What's the output of the following commands?

$ LC_CTYPE=ja_JP.UTF-8 fc-match sans | head
$ LC_CTYPE=ja_JP.UTF-8 fc-match sans-serif | head

Kenichi Ito (ken-i54k) wrote :

In a live session
$ LC_CTYPE=ja_JP.UTF-8 fc-match sans | head
fonts-japanese-gothic.ttf: "Takao Pゴシック" "Regular"
$ LC_CTYPE=ja_JP.UTF-8 fc-match sans-serif | head
fonts-japanese-gothic.ttf: "Takao Pゴシック" "Regular"

However, how should I debug in the first screen "Install (as superuser)" on starting?

Kenichi Ito (ken-i54k) wrote :

Hmm, I can reproduce in a live session by selecting it from boot menu.
But the outputs is same.

Adolfo Jayme (fitojb) on 2016-03-13
affects: ubuntu-translations → ubiquity-slideshow-ubuntu (Ubuntu)
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
importance: Undecided → High
tomoe_musashi (musashi) wrote :

In the first screen, it pick up fonts-arphic-ukai, then fallback to TakaoPGothic.
But after selecting "try ubuntu without installing" with ja lang, the system pick up TakaoPGothic first, then fallback to fonts-arphic-ukai.
Seems like 65-fonts-arphic-ukai.conf and 65-fonts-arphic-uming.conf are affecting font fallback.

Gunnar Hjalmarsson (gunnarhj) wrote :

The fact that the 65-fonts-arphic-*.conf files are present makes me think that adding fonts-takao-pgothic to:

http://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/ubuntu.xenial/view/head:/live

and

http://bazaar.launchpad.net/~ubuntu-mate-dev/ubuntu-seeds/ubuntu-mate.xenial/view/head:/live

might make a difference.

Gunnar Hjalmarsson (gunnarhj) wrote :

I've changed my mind. Considering what tomoe_musashi let us know in comment #7, this may simply be about how different available fonts, which handle Japanese, are prioritized. In that case it can be handled in a fontconfig .conf file.

I added a new fontconfig .conf file to language-selector-common, and uploaded the language-selector source package. This *might* fix this issue.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in language-selector (Ubuntu):
status: New → Confirmed
affects: ubuntu-meta (Ubuntu) → language-selector (Ubuntu)
Changed in language-selector (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: New → Fix Committed
no longer affects: ubuntu-mate-meta (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.161

---------------
language-selector (0.161) xenial; urgency=medium

  * fontconfig/64-language-selector-prefer.conf,
    debian/language-selector-common.links:
    Prevent that UKai and UMing is picked over default Chinese and
    Japanese fonts when the locale is something else but Chinese or
    Japanese (LP: #1468027, LP: #1540063).

 -- Gunnar Hjalmarsson <email address hidden> Sun, 13 Mar 2016 14:02:00 +0100

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
Kenichi Ito (ken-i54k) wrote :

I tried language-selector - 0.161, and it was better.
But it seems still a Chinese font(Noto Sans?)

Gunnar Hjalmarsson (gunnarhj) wrote :

@Kenichi: To be perfectly honest, I don't know how to see that. (I speak neither Chinese nor Japanese.)

It's true that the Chinese Noto Sans fonts are now preferred before Takao:

https://bugs.launchpad.net/ubuntu/+source/language-selector/+bug/1468027/comments/68

Are some characters present in both Chinese and Japanese? If so, I imagine that the result of the current config file may be a mix of Noto Sans and Takao supported rendering.

In that case it would possibly be better to replace Takao with the Japanese Noto Sans fonts in that config file, so Japanese contents is consistently rendered using Noto Sans as long as the locale is not Japanese.

Kenichi Ito (ken-i54k) wrote :

>Are some characters present in both Chinese and Japanese?
Yes. Chinese font and Japanese font are different in the same character.
That's why Noto Sans CJK {JP, KR, SC, TC} exists.

Gunnar Hjalmarsson (gunnarhj) wrote :

Ok, I made the change I mentioned (Takao -> Noto Sans) and uploaded to this PPA:

https://launchpad.net/~gunnarhj/+archive/ubuntu/japanese-fonts

Can you please test, and let us know if it possibly improves the Japanese rendering with a non-CJKV locale.

Kenichi Ito (ken-i54k) on 2016-03-14
affects: ubiquity-slideshow-ubuntu (Ubuntu) → ubiquity (Ubuntu)
Gunnar Hjalmarsson (gunnarhj) wrote :

Another thought:

When running fc-match with the config file disabled, the Japanese font is consequently listed first. Wondering if it would be possible to place the Japanese lines first in the config file, without messing up the Chinese rendering.

$ LC_CTYPE=en_US.UTF-8 fc-match -a | grep -i noto
NotoSansCJK.ttc: "Noto Sans CJK JP" "DemiLight"
NotoSansCJK.ttc: "Noto Sans CJK KR" "DemiLight"
NotoSansCJK.ttc: "Noto Sans CJK SC" "DemiLight"
NotoSansCJK.ttc: "Noto Sans CJK TC" "DemiLight"
NotoSansCJK.ttc: "Noto Sans CJK JP" "Regular"
NotoSansCJK.ttc: "Noto Sans CJK KR" "Regular"
NotoSansCJK.ttc: "Noto Sans CJK SC" "Regular"
NotoSansCJK.ttc: "Noto Sans CJK TC" "Regular"
NotoSansCJK.ttc: "Noto Sans Mono CJK JP" "Regular"
NotoSansCJK.ttc: "Noto Sans Mono CJK KR" "Regular"
NotoSansCJK.ttc: "Noto Sans Mono CJK SC" "Regular"
NotoSansCJK.ttc: "Noto Sans Mono CJK TC" "Regular"
NotoSansCJK.ttc: "Noto Sans CJK JP" "Medium"
NotoSansCJK.ttc: "Noto Sans CJK KR" "Medium"
NotoSansCJK.ttc: "Noto Sans CJK SC" "Medium"
NotoSansCJK.ttc: "Noto Sans CJK TC" "Medium"
NotoSansCJK.ttc: "Noto Sans CJK JP" "Thin"
NotoSansCJK.ttc: "Noto Sans CJK KR" "Thin"
NotoSansCJK.ttc: "Noto Sans CJK SC" "Thin"
NotoSansCJK.ttc: "Noto Sans CJK TC" "Thin"
NotoSansCJK.ttc: "Noto Sans CJK JP" "Light"
NotoSansCJK.ttc: "Noto Sans CJK KR" "Light"
NotoSansCJK.ttc: "Noto Sans CJK SC" "Light"
NotoSansCJK.ttc: "Noto Sans CJK TC" "Light"
NotoSansCJK.ttc: "Noto Sans CJK JP" "Bold"
NotoSansCJK.ttc: "Noto Sans CJK KR" "Bold"
NotoSansCJK.ttc: "Noto Sans CJK SC" "Bold"
NotoSansCJK.ttc: "Noto Sans CJK TC" "Bold"
NotoSansCJK.ttc: "Noto Sans Mono CJK JP" "Bold"
NotoSansCJK.ttc: "Noto Sans Mono CJK KR" "Bold"
NotoSansCJK.ttc: "Noto Sans Mono CJK SC" "Bold"
NotoSansCJK.ttc: "Noto Sans Mono CJK TC" "Bold"
NotoSansCJK.ttc: "Noto Sans CJK JP" "Black"
NotoSansCJK.ttc: "Noto Sans CJK KR" "Black"
NotoSansCJK.ttc: "Noto Sans CJK SC" "Black"
NotoSansCJK.ttc: "Noto Sans CJK TC" "Black"

But before trying that, it would be great to know the result of the current PPA version of language-selector.

Kenichi Ito (ken-i54k) wrote :

>the current PPA version of language-selector
the change is nothing.

Should ubiquity change the locale?
Japanese font should show in Japanese.
Chinese font should show in Chinese.

I wonder that other applications aren't affected.

Kenichi Ito (ken-i54k) wrote :

Besides, the current state is the same as 15.10(Wily).

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2016-03-14 23:21, Kenichi Ito wrote:
>> the current PPA version of language-selector
> the change is nothing.

I see. I uploaded another variant to the PPA, which really should make a difference for Japanese. (The reservation is whether it has negative side effects for Chinese.)

I don't think you need to use Ubiquity to test it. It ought to be sufficient to run a session with English as display language and view Japanese contents.

> Should ubiquity change the locale?
> Japanese font should show in Japanese.
> Chinese font should show in Chinese.

Yes, ideally. But you can't switch locale on-the-fly within a normal desktop session; you need to log out and log in again. I suspect that the Ubiquity behavior has something to do with that.

> I wonder that other applications aren't affected.

Because you don't usually switch locale within a normal session?

> Besides, the current state is the same as 15.10(Wily).

I fear it has been this way in multiple versions.

Gunnar Hjalmarsson (gunnarhj) wrote :

ping

Kenichi, can you please confirm that the latest PPA version is an improvement when rendering Japanese contents under a non-CJKV locale? Or somebody else?

Changed in language-selector (Ubuntu):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.162

---------------
language-selector (0.162) xenial; urgency=medium

  * fontconfig/64-language-selector-prefer.conf:
    Make Japanese contents be rendered using "Noto Sans CJK JP" in
    case of a non-CJKV locale (LP: #1540063, LP: #1468027).

 -- Gunnar Hjalmarsson <email address hidden> Wed, 16 Mar 2016 15:07:00 +0100

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
Kenichi Ito (ken-i54k) wrote :

I confirmed that the latest PPA version was improved when rendering Japanese under a non-CJKV locale.
But it may have negative effects for Chinese under a non-CJKV locale, because the font is changed.
(I am a native speaker of Japanese but not Chinese.)

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks Kenichi!

Yes, as you probably have seen at bug #1468027, we are talking about the Chinese side of it right now. Possibly we'll need to lower the precedence of Japanese to not cause a regression for Chinese users. Can't tell right now.

I'm sure the Daily Build ISO just prior to publishing the Final Beta.
However, this problem is getting worse unfortunately.
In Lubuntu not been able to see some of the Japanese
.

Gunnar Hjalmarsson (gunnarhj) wrote :

Well, it's not a surprise that it gets worse in Lubuntu, since they unfortunately not seed fonts-noto-cjk yet.

https://code.launchpad.net/~gunnarhj/ubuntu-seeds/lubuntu.xenial_chinese-fonts/+merge/288194

It would be good if you could try Ubuntu or Ubuntu MATE also, and let us know how it looks there.

I understand. Lubuntu of the problem separately treats from this.

I have confirmed the installation operating in the Daily Build ISO of each flavor.
As a result, I was sure that the display properly in all flavors other than Lubuntu.

Lubuntu is promoted as another problem (I added here):
https://bugs.launchpad.net/ubuntu-seeds/+bug/1437875

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers